tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From newToMina <askme...@yahoo.com>
Subject Re: Jsp working fine from tomcat, but displaying source when accessed through apache (Only on Firefox)
Date Fri, 19 Jun 2009 13:44:58 GMT

Mark,

I changed JKMount as you suggested. But firefox is still displaying the
source when accessing through apache. Direct tomcat access displays fine.
Firefox is rendering the page as follows:

Direct from tomcat (http://server:8080/appname/servlet/Controller)
Type : text/html
Render Mode: Standards compliance mode

Access tomcat through apache (http://server/appname/servlet/Controller)
Type : text/plain
Render Mode: Quirks mode

Could any one please help me with this?


markt-2 wrote:
> 
> newToMina wrote:
>> Mark, could you please explain it a little more detail and provide an
>> example
>> of the proper JKmount entries. Thanks in advance ...
> 
> Replace what you have previously with:
> 
> JkMount /appname/* tomcat5
> JkMount /appname   tomcat5
> 
> Note this means you do not use the Alias or Directory settings you had
> previously.
> 
> Mark
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Jsp-working-fine-from-tomcat%2C-but-displaying-source-when-accessed-through-apache-%28Only-on-Firefox%29-tp22931646p24111800.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message