tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Hoffer <dhoff...@gmail.com>
Subject Re: How to configure Tomcat 6.0 with JAAS?
Date Wed, 13 May 2009 13:17:27 GMT
Thanks, if possible could you/someone send some examples of how to configure
JAAS with JBoss?  I have it working with Tomcat but need the minimum
configuration to do the same for JBoss.

Note, I have a servlet that at startup sets the JAAS configuration, i.e.
Configuration.setConfiguration(configuration) which sets the LoginModule to
use.  I just need to know how to configure JBoss to work with this
LoginModule.

-Dave

On Tue, May 12, 2009 at 10:56 AM, Caldarale, Charles R <
Chuck.Caldarale@unisys.com> wrote:

> > From: Christopher Schultz [mailto:chris@christopherschultz.net]
> > Subject: Re: How to configure Tomcat 6.0 with JAAS?
> >
> > ... though JBoss uses Tomcat as its default servlet container
>
> Unfortunately, JBoss does not use Tomcat's authentication - it has its own.
>  When we wrote JAAS modules for use on our proprietary OS, we had to do
> separate implemenations for JBoss and Tomcat.
>
>  - Chuck
>
>
> THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
> MATERIAL and is thus for use only by the intended recipient. If you received
> this in error, please contact the sender and delete the e-mail and its
> attachments from all computers.
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message