tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Xie Xiaodong <xxd82...@gmail.com>
Subject Re: Application-specific jar files with Tomcat v6.0
Date Fri, 01 May 2009 15:38:42 GMT
Hi,
   Are there any conflict between your jar and those jars used by Tomcat?



2009/4/30 <Shiping.Chen@csiro.au>

> Hi,
>
> I am deploying an axis2 web service with Tomcat v6.0.
>
> The web service required a third-part jar file, say x.jar
> I can make the work service working with Axis2 standalone server by putting
> x.jar into [axis2_home]/lib.
>
> According to Tomcat documents and corresponding discussion, I put x.jar
> into [Tomcat 6.0_home]\webapps\axis2\WEB-INF\lib, as deploying with Tomcat
> 6.However, it does NOT work!
>
> Then, I tried to put x.jar onto [Tomcat 6.0_home]\lib, although I
> understand it is not a good idea.
> It still does NOT work!
>
> At end, I add x.jar to the java classpath using the Tomcat 6 configure GUI
> (the small icon).
> It works this time!
>
> So I wonder if it is a bug of Tomcat 6, or I did something wrong.
> I suppose that it be a very common issue and have been heavily discussed.
> Why it is still there?
>
> I would be very grateful if I can get an answer. In addition, other users
> may also have experienced the same issue.
>
>
> Thanks,
> --
> Shiping.chen@csiro.au<mailto:Shiping.chen@csiro.au>
>
>
>
>
>
>


-- 
Sincerely yours and Best Regards,
Xie Xiaodong

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message