tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From will trillich <trill...@gmail.com>
Subject Re: trouble starting tomcat: "error 0" on Windows 64bit SOLVED
Date Sun, 17 May 2009 01:57:38 GMT
On Sat, May 16, 2009 at 7:35 PM, Caldarale, Charles R
<Chuck.Caldarale@unisys.com> wrote:
>> No catalina.out at all, and stderr and stdout are empty. Only the
>> jakarta logs from when we tried running it as a service had any info,
>> as previously reported.

> That's because of your incorrect "server" option - tomcat never got started, so no logs
were written.  All of the above come from the service wrapper.

Yes indeed, this one boiled down to a cut-and-paste error when
populating JAVA_OPTS: should have, but didn't, included the leading
dash for "-server".

Original error, when trying to start as a service:
"The Apache Tomcat service terminated with service-specific error 0 (0x0)."
There was no logfile, no ports opened, no diagnostic text at all.

When trying to start from the command line, no text, no errors,
nothing, just instant quit.

JAVA_OPTS should have included "-server" but didn't: the initial dash
was missing ("server" without the leading "-").

-- 
will trillich
"Our only real economic security lies in our power to meet human
needs." -- S.Covey, the 8th Habit

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message