tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "will@serensoft.com" <w...@serensoft.com>
Subject trouble starting tomcat: "error 0" on Windows 64bit
Date Sat, 16 May 2009 05:17:39 GMT
We're having a heck of a time getting tomcat running on windows server
2003 enterprise x64 -- it barely gets started, and instantly quits. We
installed java from jdk-1_5_0_18-windows-amd64.exe  which seems to be
the only 64-bit version available? Our processor is intel, tho... Is
there an intel-not-amd version we missed?


All we get is "error 0x0"...?

This is on Windows Server 2003 R2 Enterprise x64 (SP2) -- Yes, this is
a 64-bit machine

Tried tomcat from both apache-tomcat-5.5.27.exe installer and from straight ZIP

Java is 1.5.0_18

Java has no spaces in its path: C:\Java\jdk1.5.0_18 (from
jdk-1_5_0_18-windows-amd64.exe installer)

No port conflicts (we're asking for port 80 instead of 8080) according
to netstat -an


yes, we're listening on port 80 instead of 8080 (via server.xml);
Tomcat has no spaces in its path: C:\Tomcat55

Executing "tomcat5.exe" from the command line shows only a blank line,
then the command prompt pops up again (no text-to-console logged).

Executing "startup.bat" shows
Using CATALINA_BASE:   C:\Tomcat55
Using CATALINA_HOME:   C:\Tomcat55
Using CATALINA_TMPDIR: C:\Tomcat55\temp
Using JRE_HOME:        C:\Java\jdk1.5.0_18

We've tried running it as a service (setting it up via 'service.bat'), too:

The start>admin>componentServices>event viewer shows only:
"""
The Apache Tomcat service terminated with service-specific error 0 (0x0).

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.
"""

C:\Tomcat55\logs>type jakarta_service_20090515.log
[2009-05-15 15:03:59] [info] Procrun (2.0.4.0) started
[2009-05-15 15:03:59] [info] Service sakai name Apache Tomcat sakai
[2009-05-15 15:04:00] [info] Service sakai installed
[2009-05-15 15:04:00] [info] Procrun finished.
[2009-05-15 15:04:00] [info] Procrun (2.0.4.0) started
[2009-05-15 15:04:00] [info] Updating service...
[2009-05-15 15:04:00] [info] Service sakai updated
[2009-05-15 15:04:00] [info] Update service finished.
[2009-05-15 15:04:00] [info] Procrun finished.
[2009-05-15 15:04:00] [info] Procrun (2.0.4.0) started
[2009-05-15 15:04:00] [info] Updating service...
[2009-05-15 15:04:00] [info] Service sakai updated
[2009-05-15 15:04:00] [info] Update service finished.
[2009-05-15 15:04:00] [info] Procrun finished.
[2009-05-15 15:05:19] [info] Procrun (2.0.4.0) started
[2009-05-15 15:05:19] [info] Running Service...
[2009-05-15 15:05:19] [info] Starting service...
[2009-05-15 15:05:19] [174  javajni.c] [error] %1 is not a valid Win32
application.
[2009-05-15 15:05:19] [994  prunsrv.c] [error] Failed creating java
C:\Java\jdk1.5.0_18\jre\bin\server\jvm.dll
[2009-05-15 15:05:19] [1269 prunsrv.c] [error] ServiceStart returned 1
[2009-05-15 15:05:19] [info] Run service finished.
[2009-05-15 15:05:19] [info] Procrun finished.

Both stderr and stdout logs are empty.

We did find a thread online that recommended "copy the file
msvcr71.dll from the bin dir of your java installation, to the bin dir
of the tomcat installation." Of course, we don't have a msvcr71 (tho
we did find a msvcrt.dll which didn't do the trick.)

Any pointers would be great!


-- 
will trillich
"Our only real economic security lies in our power to meet human
needs." -- S.Covey, the 8th Habit

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message