tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Biebl <mbi...@gmail.com>
Subject Re: problems with mod_proxy (apache 2.2.9) and tomcat ajp connector (6.0.18)
Date Thu, 28 May 2009 09:16:26 GMT
2009/5/27 Guy Cube <guyinthecube@gmail.com>:
>
> Any found clue for this issue? We are also having similar issue with JBoss
> 4.2.3/Apache 2.2.9 and mod_proxy_ajp.

I haven't found a solution yet. On the other hand, I haven't seen
those issues for some time now. I tried to do some load tests but it
seems I wasn't able to trigger those problems in a reliable way.

>
> On JBoss side, ajp connections are hanging there. in netstat -an we saw
> AJP's tcp connections were in ESTABLISHED state and stay there forever.

I've seen that too, iirc. I had around 400 open connections on
tcp/tcp6 on port 8009.

>
> Can anyone give us clue, how to fix it?

Unfortunately not.
Just curious: Do you also run a Debian lenny kernel?

> Guy
>
>
>
> Michael Biebl-2 wrote:
>>
>> Hi,
>>
>> first of all, I'd like to say hi, as I'm new to the list.
>>
>> I hope you can help me with the following problem I have.
>> I run a stock Debian lenny installation with apache 2.2.9 and tomcat
>> 6.0.18
>> I'm using mod_proxy to forward the request to tomcat using ajp. The
>> apache vhost configuration looks like this:
>>
>> <VirtualHost *:80>
>>
>> ...
>>         ProxyRequests Off
>>         ProxyVia On
>>         ProxyPass /t/ ajp://localhost:8009/barcooServer/t/
>>         ProxyPass /ws/ ajp://localhost:8009/barcooServer/ws/
>>         ProxyPass /reports/ ajp://localhost:8009/barcooServer/reports/
>>         ProxyPass / ajp://localhost:8009/barcooWebsite/
>>         ProxyPassReverse / ajp://localhost:8009/barcooWebsite/
>>         ProxyPassReverseCookiePath /barcooWebsite /
>> ...
>>
>> </VirtualHost>
>>
>> The apache mpm prefork modules is used with the following configuration.
>> <IfModule mpm_prefork_module>
>>     StartServers          5
>>     MinSpareServers       5
>>     MaxSpareServers      10
>>     MaxClients          200
>>     MaxRequestsPerChild   0
>> </IfModule>
>>
>> The tomcat ajp connector configuration is as simple as
>> <Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />
>>
>>
>> Now, when I get a lot of users access, the http connection via apache
>> slows down to a crawl
>> and I get a lot of the following messages in the kernel log:
>>
>> [2350915.113736] __ratelimit: 11 messages suppressed
>> [2350915.113742] TCPv6: Possible SYN flooding on port 8009. Dropping
>> request.
>>
>> apache and tomcat itself seem to be idling along, and the load is not
>> that high on the machine.
>>
>> Has anyone an idea what's going on there?
>>
>> Thanks in advance for your help,
>> Michael
>>
>> --
>> Why is it that all of the instruments seeking intelligent life in the
>> universe are pointed away from Earth?
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
>>
>
> --
> View this message in context: http://www.nabble.com/problems-with-mod_proxy-%28apache-2.2.9%29-and-tomcat-ajp-connector--%286.0.18%29-tp23501257p23737358.html
> Sent from the Tomcat - User mailing list archive at Nabble.com.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>



-- 
Why is it that all of the instruments seeking intelligent life in the
universe are pointed away from Earth?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message