tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Lenart" <clen...@comcast.net>
Subject RE: Tomcat Configuration in Eclipse
Date Fri, 08 May 2009 18:33:32 GMT
It's on a pc  / xp. I had it working before and had reformat  my drive.
Nothing has changed.

-----Original Message-----
From: Mike Altieri [mailto:mcapsu@yahoo.com] 
Sent: Friday, May 08, 2009 1:03 PM
To: Tomcat Users List
Subject: Re: Tomcat Configuration in Eclipse



Hi Chris,

Make sure to check out Larry's post - he picked up that a different
plug-in may be being used in the original post.

The sysdeo plugin has something similar in its config:
they're doc:
http://www.eclipsetotale.com/articles/tomcat/tomcatPluginDocFR.html  
(Its in french but using google to translate it looks like it has
something similar under configuration step #3)

It depends on what you are coding/testing...
If you only need the web-apps you are working on to be running on that
box; and its your local laptop/dev box I would likely leave it at
default. (not to modify the tomcat install)

If you'd like to run the app you are coding along side other
applications (that aren't in your eclipse workspace) I'd pick use tomcat
installation....

It really depends on what you are trying to accomplish and your env.

-Mike



----- Original Message ----
> From: Chris Lenart <clenart@comcast.net>
> To: Tomcat Users List <users@tomcat.apache.org>
> Sent: Friday, May 8, 2009 1:49:16 PM
> Subject: RE: Tomcat Configuration in Eclipse
> 
> Mike,
> 
> What would you do if you want to get it working so you can code and 
> test?
> 
> -----Original Message-----
> From: Mike Altieri [mailto:mcapsu@yahoo.com]
> Sent: Friday, May 08, 2009 11:12 AM
> To: Tomcat Users List
> Subject: Re: Tomcat Configuration in Eclipse
> 
> 
> 
> Hi Ados,
> 
> Ognjen is right; the default setting in the eclipse plugin for tomcat6

> is to use the workspace metadata; this way when you start tomcat from 
> eclipse only the projects you have deployed on it inside of eclipse 
> will be the running apps.
> 
> If you want you can alter this setting by double clicking on the 
> server; and when the serve config opens look under 'Server Locations' 
> ; if you choose the 'use tomcat installation' then all the apps that 
> are installed in your server should also start when you start the 
> server inside of eclipse.
> 
> This may or may not be desirable depending on your environment's 
> needs.
> 
> Good Luck!
> 
> -Mike
> 
> 
> 
> ----- Original Message ----
> > From: "ados1984@gmail.com"
> > To: Tomcat Users List 
> > Sent: Friday, May 8, 2009 11:17:02 AM
> > Subject: Re: Tomcat Configuration in Eclipse
> > 
> > I am stuck on same issue. I tried reconfiguring Tomcat on Eclipse
> > using sysdeo plugin but when I try to run simple jsp page am getting

> > same 404 error. Any help would be highly appreciated ?
> > 
> > Thanks,
> > Ados
> > 
> > On Fri, May 8, 2009 at 8:51 AM, Chris Lenart wrote:
> > 
> > > I'm getting simular issue. Tomcat is working and see its welcome
> > > page in Firefox. When I run a imple jsp in Eclipse, it is giving 
> > > 404. What do I have to do?
> > >
> > > Chris
> > >
> > > -----Original Message-----
> > > From: Ognjen Blagojevic [mailto:ognjen@etf.bg.ac.rs]
> > > Sent: Friday, May 08, 2009 4:50 AM
> > > To: Tomcat Users List
> > > Subject: Re: Tomcat Configuration in Eclipse
> > >
> > >
> > > This is normal.
> > >
> > > When you start Tomcat manually, it uses YOUR-TOMCAT-HOME/webapps 
> > > as
> > > default webapp directory. This directory contains "ROOT" webapp 
> > > (visible
> > >
> > > on context "/"), and that is the welcome page you see.
> > >
> > > On the other side, when you start Tomcat inside Eclipse, it uses
> > > some other webapp folder like 
> > >
YOUR-ECLIPSE-WORKSPACE/.metadata/.plugins/org.eclipse.wst.server.cor
> > > e/tm
> > > p0/wtpwebapps,
> > > which doesn't contains ROOT webapp (or, sometimes contains blank
> ROOT
> > > webapp). In that case on context "/" (http://localhost:8080/), you
> will
> > > get either HTTP error 404 or blank page.
> > >
> > > Regards,
> > > Ognjen
> > >
> > >
> > > ados1984@gmail.com wrote:
> > > > Interesting Things are happening with my Tomcat.
> > > >
> > > > Points to Note:
> > > >
> > > >
> > > >    1. I am installing tomcat version 6.x and than running it by
> > > clicking
> > > >    startup.bat file and it is running fine as when I check in
> > > > browser
> > > typing
> > > >    http://localhost:8080/ it shows me the Apache Foundation
> > > > Welcome
> > > pages
> > > >    saying that Installation works fine.
> > > >    2. Interesting thing to note is that when I stop my server
> using
> > > >    shutdown.bat file than it work fine but now if I start my
> > > > server
> > > using
> > > >    eclipse than it starts but when I go to browser to check 
> > > > Apache
> > > Foundation
> > > >    Welcome Page than it is not there and I get message as under
> > > > and it
> > > is
> > > >    confusing.
> > > >
> > > >
> > > > Apache Tomcat/6.0.18 - Error report
> > > > Apache Tomcat/6.0.18 - Error report HTTP Status 404 - /
> > > > ------------------------------
> > > >
> > > > *type* Status report
> > > >
> > > > *message* */*
> > > >
> > > > *description* *The requested resource (/) is not available.*
> > > > ------------------------------
> > > > Apache Tomcat/6.0.18
> > > >
> > > >
> > > > Any guidance would be appreciated.
> > >
> > > ------------------------------------------------------------------
> > > --
> > > -
> > > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > > For additional commands, e-mail: users-help@tomcat.apache.org
> > >
> > >
> > > ------------------------------------------------------------------
> > > --
> > > -
> > > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > > For additional commands, e-mail: users-help@tomcat.apache.org
> > >
> > >
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message