tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Migrating website from own server to hosting company
Date Mon, 25 May 2009 15:09:46 GMT
dfobox wrote:
> Hi all,
> we have a website running under Tomcat 4 on old Linux box. it works
> flawlessly, but decision was made to move it to hosting company server with
> Tomcat 6 on it. 
> I've copied website to freshly installed Tomcat 6.0.18 on my Mac, imported
> database with phpMyAdmin, changed tomcat-users.xml file for authentication
> on admin part, put mysql-connector-java-5.0.8-bin.jar (for JDBC connection)
> to WEB-INF/lib and voila - it works just perfect. 
> history with instance on hosting server is much longer, but now website
> seems to be working except when resizing of image is being performed.
> whenever user adds content with picture, error comes out 
> 
> java.lang.NoClasDefFoundError: com/sun/media/jai/codec/ImageEncodeParam
> 
> JAI is Java Advanced Imaging API, on both working servers I have only
> jai_codec.jar, jai_core.jar and jai_imageio.jar in
> $CATALINA_HOME/webapps/ROOT/WEB-INF/classes folder. There are installation
> instructions for JAI on java.sun.com, but I'm not sure if I can do it on
> hosting server...
> any clues will be greatly appreciated. 
> best, Ivan
Just my 0.02 Euro : should they not be in 
$CATALINA_HOME/webapps/ROOT/WEB-INF/lib ?



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message