tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pid...@pidster.com>
Subject Re: hot-deploy problems
Date Fri, 01 May 2009 15:39:47 GMT
Umm, are you uploading war files directly to the webapps directory?

p



Peter Crowther wrote:
> Tomcat version?
> Java version?
> OS?
> 
>> -----Original Message-----
>> From: david owens [mailto:ymidt@yahoo.com]
>> Sent: 01 May 2009 15:52
>> To: users@tomcat.apache.org
>> Subject: hot-deploy problems
>>
>>
>> I hope you folks are not sick to death of this question, but
>> I have still not found a satisfactory answer.
>>
>> I used to hot-deploy war files with no problems, and about
>> half the time I get "ZipException: error in opening zip
>> file", or "Illegal access: this web application
>> instance has been stopped already." errors.
>>
>> I don't currently specify a config.xml and it seems to
>> have something to do with that (docbase and appbase being
>> the same?).
>>
>> But I hate to add app configurations that are not contained
>> in the war files themselves.  Is there a way to solve this
>> with the META-INF/config.xml?  If so, can someone please
>> provide an example?  If not, what is the best solution?  (I
>> have no spaces or other unusual characters in my jar or war
>> file names, and half the time things work fine).
>>
>> Thank you much,
>> -- David D.
>>
>>
>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message