tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kvancamp <ken.vanc...@andesaservices.com>
Subject Re: AJP connections just stop working
Date Wed, 27 May 2009 12:36:52 GMT


Guy Cube wrote:
> 
> Hello,
> 
> We are also haveing exact same issue in our environment. We are using
> JBoss 4.2.3, Apache 2.2.11 with mod_proxy_ajp using ajp to connect between
> Apache and JBoss. It happens intermittently and when i happnes all AJP's
> TCP connections are stayed in ESTABLISHED state on JBoss machine. In
> thread dump, all AJP threads are in waiting state. 
> 
> Anyone found solution or work around for this issue?
> 
> Thanks,
> GC
> 

For now I have set the connectionTimeout to 10 minutes on my AJP connection,
e.g.
    <!-- Define an AJP 1.3 Connector on port 8009, timeout in 10 mins. -->
    <Connector port="8009" address="${jboss.bind.address}"
protocol="AJP/1.3"
         emptySessionPath="true" enableLookups="false" redirectPort="8443"
         connectionTimeout="600000"
    />

I am monitoring results, it is too soon to tell if this alone will solve the
problem or if I also have to delve into my firewall (I was incorrect in my
original response above - there IS a firewall between my IIS proxy and my
JBoss server, and it has a 1 hour idle tcp session timeout), or my IIS proxy
(which is configured with a 5-minute socket timeout).

Ken
-- 
View this message in context: http://www.nabble.com/AJP-connections-just-stop-working-tp1118618p23741629.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message