tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zeiss <ze...@tut.by>
Subject Using WAS 6.1 client with Tomcat 6.0
Date Tue, 26 May 2009 09:50:05 GMT

Hello,

Web application that I'm developing needs to access EJBs deployed within
WebSphere Application Server 6.1. The way to communicate with WAS described
in documentation is to use WAS client, namely
com.ibm.ws.admin.client_6.1.0.jar.

The problem with this jar is that it contains javax.servlet.http.HttpServlet
class and others, so it won't load from application's WEB-INF/lib as
offending. Thus I have to place it into lib/ext directory in JRE. This works
until the compilation of JSP is required - then Jasper fails since it uses
classes loaded previously from com.ibm.ws.admin.client_6.1.0.jar instead of
those from jsp-api.jar and servlet-api.jar. JSP-related classes in
com.ibm.ws.admin.client_6.1.0.jar implement Servlet 2.4/JSP 2.0 while Jasper
in Tomcat 6.0 requires 2.5/2.1.

Is there any smart way to get this working, I mean using JSPs along with WAS
6.1 client?
-- 
View this message in context: http://www.nabble.com/Using-WAS-6.1-client-with-Tomcat-6.0-tp23719994p23719994.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message