tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From samr <woods...@gmail.com>
Subject Re: Connector Issue - Tomcat 6.0/IIS 6.0
Date Fri, 08 May 2009 18:30:05 GMT

The redirect dll name is "isapi_redirect.dll"

On the IIS: I am running IIS 6.0, .net Framework 3.5.  I have a default
website with several virtual directories.  Most of them are asp.net sites. 
"jakarta" is also another virtual directory with execute access.  The
default App pool is configured to run with "NetworkAccount". This is a part
of the IIS_WPG user group. Also, "Everyone" has Read,Execute access on the
ISAPI_REDIRECT.DLL physical folder.

Thanks for your help.
Samr

Rainer Jung-3 wrote:
> 
> I can see the problem, but I don't yet have a solution. Usually the
> filter part of the redirector hecks whether to forward, saves the URL
> and sets the special URL /jakarta/isapi_redirect.dll. Then IIS calls the
> extension part of the redirector, which extracts the saved URL and does
> the forwarding.
> 
> In your case IIS doesn't call the extension part with the special URL
> /jakarta/isapi_redirect.dll, instead it calls again the filter.
> 
> I need to think about that.
> 
> Just to make sure:
> 
> - your redirector dll is actually has the file name isapi_redirect.dll?
> - check once more, whether you did this step correctly:
> 
> Using the IIS management console, add a new virtual directory to your
> web site. The name of the virtual directory must be jakarta. Its
> physical path should be the directory where you placed
> isapi_redirect.dll. While creating this new virtual directory assign it
> with execute access.
> 
> In case I find some time to try to reproduce: anything special about
> your IIS setup?
> 
> Regards,
> 
> Rainer
> 
> On 07.05.2009 16:05, samr wrote:
>> Accessing the same url from localhost:8080 displays the page without any
>> problem. 
>> 
>> I have attached the IIS_Redirect log when accessing the url
>> :http://localhost/examples/jsp/jsp2/el/basic-arithmetic.jsp
>> 
>> The IIS Log from W3SVC for the same is:
>> 
>> #Software: Microsoft Internet Information Services 6.0
>> #Version: 1.0
>> #Date: 2009-05-07 14:02:08
>> #Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query
>> s-port
>> cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status 
>> 2009-05-07 14:02:08 W3SVC1 127.0.0.1 GET
>> /examples/jsp/jsp2/el/basic-arithmetic.jsp - 80 - 127.0.0.1
>> Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729)
>> 200 0 0
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> Rainer Jung-3 wrote:
>>> Your log snippet indicates, that the request was successfully forwarded
>>> to Tomcat and Tomcat returned with 404. Since you left out to much from
>>> the log, we can't say for sure, whether thew request in the redirector
>>> log is the same, as the 200 request in the IIS log.
>>>
>>> If you can provide access to more of the log, we can check that.
>>>
>>> Try to access the same URL that gives you a 404 directly via the HTTP
>>> port of Tomcat (usually 8080). If you get the same result there, then
>>> you first need to correct your Tomcat installation. If that works, but
>>> not via IIS, then provide the full redirector log of the startup and the
>>> single request that doesn't work for you.
>>>
>>> Regards,
>>>
>>> Rainer
>>>
>>> On 06.05.2009 23:43, samr wrote:
>>>> Following are the versions of software I have installed on Windows2003
>>>> Server
>>>> SP2
>>>> Tomcat-6.0.18
>>>> Java - Version 6 Update 13 
>>>> IIS - 6.0
>>>> Tomcat Connector - 1.2.28
>>>>
>>>> I have done the configuration consulting the tomcat site.Here is how
>>>> isapi_redirect.properties looks like:
>>>> extension_uri=/jakarta/isapi_redirect.dll
>>>> log_file=c:\Tomcat\logs\iis_redirect.log
>>>> log_level=debug
>>>> worker_file=C:\Tomcat\conf\workers.properties
>>>> worker_mount_file=C:\Tomcat\conf\uriworkermap.properties
>>>>
>>>> Workers.properties
>>>>
>>>> worker.list=ajp13
>>>> worker.ajp13.host=localhost
>>>> worker.ajp13.port = 8009
>>>> worker.ajp13.type = ajp13
>>>>
>>>>
>>>> uriworkermap.properties
>>>> /examples/*=ajp13
>>>>
>>>>
>>>>
>>>> When I try to access a jsp page using
>>>> IIS(http://localhost/examples/jsp/jsp2/el/basic-arithmetic.jsp)
>>>> I get a Http Status 404 eror from Tomcat
>>>>
>>>>
>>>> The IIS_Redirect log with 400 error is here(I am just pasting a few
>>>> lines
>>>> that are relevant, the redirect calls happen fine)
>>>>
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_util.c (455):
>>>> Pre-processed log time stamp format is '[%a %b %d %H:%M:%S.000 %Y] '
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [info] jk_isapi_plugin.c
>>>> (2398):
>>>> Starting Jakarta/ISAPI/isapi_redirector/1.2.28
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_isapi_plugin.c
>>>> (2416):
>>>> Detected IIS version 6.0
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_isapi_plugin.c
>>>> (2418):
>>>> Using ini file C:\Tomcat\ISAPI\isapi_redirect.properties.
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_isapi_plugin.c
>>>> (2424):
>>>> Using log file c:\Tomcat\logs\iis_redirect.log.
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_isapi_plugin.c
>>>> (2425):
>>>> Using log level 1.
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_isapi_plugin.c
>>>> (2426):
>>>> Using extension uri /jakarta/isapi_redirect.dll.
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_isapi_plugin.c
>>>> (2427):
>>>> Using worker file C:\Tomcat\conf\workers.properties.
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_isapi_plugin.c
>>>> (2428):
>>>> Using worker mount file C:\Tomcat\conf\uriworkermap.properties.
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_isapi_plugin.c
>>>> (2430):
>>>> Using rewrite rule file .
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_isapi_plugin.c
>>>> (2432):
>>>> Using uri select 3.
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_isapi_plugin.c
>>>> (2433):
>>>> Using no chunked encoding.
>>>> ...
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_map.c (490):
>>>> Adding
>>>> property '/examples/*' with value 'ajp13' to map.
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_uri_worker_map.c
>>>> (1101): Loading urimaps from C:\Tomcat\conf\uriworkermap.properties
>>>> with
>>>> reload check interval 60 seconds
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_uri_worker_map.c
>>>> (719): wildchar rule '/examples/*=ajp13' source 'uriworkermap' was
>>>> added
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_uri_worker_map.c
>>>> (171): 
>>>> ....
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_worker.c (242):
>>>> creating worker ajp13
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_worker.c (146):
>>>> about
>>>> to create instance ajp13 of ajp13
>>>> ...
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_uri_worker_map.c
>>>> (171): uri map dump after extension stripping: index=0
>>>> file='C:\Tomcat\conf\uriworkermap.properties' reject_unsafe=0 reload=60
>>>> modified=1241645359 checked=1241645464
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_uri_worker_map.c
>>>> (176): generation 0: size=0 nosize=0 capacity=0
>>>> ..
>>>> [Wed May 06 16:31:04.677 2009] [9352:9452] [debug] jk_ajp_common.c
>>>> (2246):
>>>> processing ajp13 with 2 retries
>>>> [Wed May 06 16:31:04.677 2009] [9352:9452] [debug] jk_ajp_common.c
>>>> (1461):
>>>> (ajp13) all endpoints are disconnected.
>>>> ...
>>>> [Wed May 06 16:31:04.677 2009] [9352:9452] [debug] jk_ajp_common.c
>>>> (1217):
>>>> received from ajp13 pos=0 len=82 max=8192
>>>> ...
>>>> [Wed May 06 16:31:04.662 2009] [9352:9452] [debug] jk_isapi_plugin.c
>>>> (2060):
>>>> [/jakarta/isapi_redirect.dll] is not a servlet url
>>>> .....
>>>> [Wed May 06 16:31:04.677 2009] [9352:9452] [debug] jk_ajp_common.c
>>>> (660):
>>>> status = 404
>>>> ....
>>>> [Wed May 06 16:31:04.677 2009] [9352:9452] [debug] jk_ajp_common.c
>>>> (1806):
>>>> AJP13 protocol: Reuse is OK
>>>> [Wed May 06 16:31:04.677 2009] [9352:9452] [debug] jk_isapi_plugin.c
>>>> (2189):
>>>> service() returned OK
>>>> [Wed May 06 16:31:04.677 2009] [9352:9452] [debug] jk_ajp_common.c
>>>> (743):
>>>> (ajp13) resetting endpoint with sd = 620 
>>>> [Wed May 06 16:31:04.677 2009] [9352:9452] [debug] jk_ajp_common.c
>>>> (2850):
>>>> recycling connection pool slot=0 for worker ajp13
>>>>
>>>> The IIS log from W3SVC shows that the get was o.k.(Code 200)
>>>>
>>>> #Software: Microsoft Internet Information Services 6.0
>>>> #Version: 1.0
>>>> #Date: 2009-05-06 21:31:04
>>>> #Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query
>>>> s-port
>>>> cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status 
>>>> 2009-05-06 21:31:04 W3SVC1 127.0.0.1 GET
>>>> /examples/jsp/jsp2/el/basic-arithmetic.jsp - 80 - 127.0.0.1
>>>> Mozilla/4.0+(compatible;+MSIE+6.0;+Windows+NT+5.2;+SV1;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729)
>>>> 200 0 0
>>>>
>>>>
>>>>
>>>> Can anyone pl.point to me if I am missing anything?
>>>>
>>>> Thanks,
>>>> Sam
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>> For additional commands, e-mail: users-help@tomcat.apache.org
>>>
>>>
>>>
>> http://www.nabble.com/file/p23427486/IIS_Redirect.txt IIS_Redirect.txt 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Connector-Issue---Tomcat-6.0-IIS-6.0-tp23416131p23451251.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message