tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gainty <>
Subject RE: Problem with maximum threads
Date Tue, 21 Apr 2009 11:53:10 GMT

did you try specifying executor attribute in your Connector e.g.

Disclaimer and Confidentiality/Verzicht und Vertraulichkeitanmerkung / Note de déni et de
This message is confidential. If you should not be the intended receiver, then we ask politely
to report. Each unauthorized forwarding or manufacturing of a copy is inadmissible. This message
serves only for the exchange of information and has no legal binding effect. Due to the easy
manipulation of emails we cannot take responsibility over the the contents.
Diese Nachricht ist vertraulich. Sollten Sie nicht der vorgesehene Empfaenger sein, so bitten
wir hoeflich um eine Mitteilung. Jede unbefugte Weiterleitung oder Fertigung einer Kopie ist
unzulaessig. Diese Nachricht dient lediglich dem Austausch von Informationen und entfaltet
keine rechtliche Bindungswirkung. Aufgrund der leichten Manipulierbarkeit von E-Mails koennen
wir keine Haftung fuer den Inhalt uebernehmen.
Ce message est confidentiel et peut être privilégié. Si vous n'êtes pas le destinataire
prévu, nous te demandons avec bonté que pour satisfaire informez l'expéditeur. N'importe
quelle diffusion non autorisée ou la copie de ceci est interdite. Ce message sert à l'information
seulement et n'aura pas n'importe quel effet légalement obligatoire. Étant donné que les
email peuvent facilement être sujets à la manipulation, nous ne pouvons accepter aucune
responsabilité pour le contenu fourni.

> Date: Tue, 21 Apr 2009 04:34:58 -0700
> From:
> To:
> Subject: Problem with maximum threads
> Hi,
> I am using Tomcat 6.0.9 with the following server.xml config file:
>      <Executor name="ThreadPool" namePrefix="catalina-exec-"
>          maxThreads="70" minSpareThreads="20"/>
>      <Connector executor="ThreadPool"
>                 port="80" protocol="HTTP/1.1"
>                 connectionTimeout="2000"
>                 redirectPort="8443" />
> The Java version I am using is JDK1.6.0_06.
> The problem is with the tomcat web app being used for a load test at 200
> messages/sec. The application runs well enough for half an hour but after
> that time, the CPU consumption is maximum and idle is 0. Also, there are
> more than 1000 threads even if I have configured the maximum threads to be
> 70 in the configuration. There is no problem in the application code.
> Where can be the problem in the Tomcat?
> Thanks,
> Anand
> -- 
> View this message in context:
> Sent from the Tomcat - User mailing list archive at
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

Windows Live™ Hotmail®:…more than just e-mail.
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message