tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Armbrust <daniel.armbrust.l...@gmail.com>
Subject Re: How to debug Error: listenerStart?
Date Wed, 01 Apr 2009 21:51:51 GMT
Ok, I've finally tracked down my specific problem.

When a filter is declared in the web.xml file:
  <filter>
  	<filter-name>requestCounter</filter-name>
  	<filter-class>com.foo.bar.FancyFilter</filter-class>
  </filter>

And the class com.foo.bar.FancyFilter is missing from the war file
that you deploy, Tomcat 5.5.25 prints this to the console:

INFO: Deploying web application archive foo.war
Apr 1, 2009 1:53:45 PM org.apache.catalina.core.StandardContext start
SEVERE: Error listenerStart
Apr 1, 2009 1:53:45 PM org.apache.catalina.core.StandardContext start
SEVERE: Context [/foo] startup failed due to previous errors

Which is really not very helpful in tracking down the problem.  I've
also seen this issue when the class path issue is much more obscure
than simply missing the class of a filter.

Why doesn't tomcat log a stack trace, so we can see what class is
missing?  It's certainly not doing anyone any favors by not logging
the cause of a SEVERE error.

Any thoughts on if this is a bug, a specific problem with my tomcat
installation, or a design decision that I don't agree with?

Thanks,

Dan

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message