tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Help with mod_jk and Apache 2.2
Date Tue, 14 Apr 2009 22:05:46 GMT
Security Management wrote:
> OK, here is the error (note that I have renamed it, I was just making sure I
> was seeing what I thought I was).  Webapp works on 8080, apache restarts
> without complaining, I verified the port is the default for the worker type
> in server.xml, and I am stumped.  Thanks for looking!
> 
> Server.xml bit:
> 
> <Connector port="8009" 
>                enableLookups="false" redirectPort="8443" protocol="AJP/1.3"
> />
> 
> The error in the mod_jk logs:
> 
> [Tue Apr 14 16:57:03 2009] [16766:3085969952] [debug] jk_translate::mod_jk.c
> (3419): missing uri map for sirrus.smc:/smc-appsuite/index
> [Tue Apr 14 16:57:03 2009] [16766:3085969952] [debug]
> jk_map_to_storage::mod_jk.c (3579): missing uri map for
> sirrus.smc:/smc-appsuite/index
> [Tue Apr 14 16:57:34 2009] [16767:3085969952] [debug] jk_translate::mod_jk.c
> (3419): missing uri map for sirrus.smc:/smc-appsuite
> [Tue Apr 14 16:57:34 2009] [16767:3085969952] [debug]
> jk_map_to_storage::mod_jk.c (3579): missing uri map for
> sirrus.smc:/smc-appsuite
> 


> Here is the mod_jk.conf bit:
> 
> LoadModule jk_module modules/mod_jk.so
> 
> JkWorkersFile /etc/httpd/conf.d/workers.properties
> 
> #JkMountFile /etc/httpd/conf.d/uriworkermap.properties
> JkMount /smc-appsuite worker1
> JkMount /smc-appsuite/* worker1
> 
> JkLogFile /var/log/httpd/mod_jk.log
> JkLogLevel debug
> JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
> JkOptions +ForwardKeySize +ForwardURICompat -ForwardDirectories
> JkRequestLogFormat "%w %V %T"
> JkShmFile /var/log/httpd/JkShmFile

I think I get it.
Are you by any chance using this within a <VirtualHost> in Apache ?
(I mean, are your browser HTTP calls directed to a VirtualHost ?)

If yes, then try adding a line
JkMountCopy All
to the lines above (in the main Apache server configuration), and retry.

If it now works, make sure you read this :
http://tomcat.apache.org/connectors-doc/reference/apache.html
and specifically the part about JkMountCopy.

You would only be one among many to get bitten by this..


> 
> Here is the workers.properties:
> 
> workers.tomcat_home=/var/www/apache-tomcat-5.5.27/
> 
> workers.java_home=/usr/java/latest

Note: As far as I know, the above two properties are deprecated, and 
should no  longer be used.

> 
> ps=/
> 
> worker.list=worker1
> 
> worker.worker1.type=ajp13
> worker.worker1.host=localhost

I would still add
worker.worker1.port=8009

> 
> 
> -----Original Message-----
> From: André Warnier [mailto:aw@ice-sa.com] 
> Sent: Tuesday, April 14, 2009 4:32 PM
> To: Security Management
> Subject: Re: Help with mod_jk and Apache 2.2
> 
> Antonio, ya me has perdido.
> 
> Would you mind re-posting the content of your 3 files, as they are now ?
> 
> Alternatively :
> - comment the line "JkMountFile"
> - add instead the two following lines
> JkMount /appsuite worker1
> JkMount /appsuite/* worker1
> 
> and tell us if that works.
> (That is, assuming that your webapp is still at /appsuite in Tomcat)
> 
> 
> 
> Security Management wrote:
>> OK, I was switching the name to make sure the logs switched the name and
>> stuff.
>>
>> It's consistent in the file.
>>
>> -----Original Message-----
>> From: André Warnier [mailto:aw@ice-sa.com] 
>> Sent: Tuesday, April 14, 2009 4:19 PM
>> To: Tomcat Users List
>> Subject: Re: Help with mod_jk and Apache 2.2
>>
>> Security Management wrote:
>>> Yeah, I saw that, and it's now:
>>>
>>> /smc-appsuite|/*=worker1
>>>
>>> Which should match /appsuite/ and /appsuite/*
>> Now wait a minute.  Why did this suddenly become "/smc-appsuite", and 
>> not like before, "/appsuite" ?
>> If you keep changing the data between questions, it becomes hard to
> follow.
>>> Still not working, though.  Same problem.  Any more ideas?
>>>
>>> Thanks for the help,
>>> Mike.
>>>
>>> -----Original Message-----
>>> From: André Warnier [mailto:aw@ice-sa.com] 
>>> Sent: Tuesday, April 14, 2009 10:03 AM
>>> To: Tomcat Users List
>>> Subject: Re: Help with mod_jk and Apache 2.2
>>>
>>> Antonio Vidal Ferrer wrote:
>>>> Hi.
>>>>
>>>> I guess the = sign in your jkmount file is wrong.
>>>> It should say:
>>>> /appsuite	worker1
>>>>
>>> Not according to this :
>>> http://tomcat.apache.org/connectors-doc/reference/uriworkermap.html
>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>> For additional commands, e-mail: users-help@tomcat.apache.org
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>> For additional commands, e-mail: users-help@tomcat.apache.org
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message