tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From George Sexton <gsex...@mhsoftware.com>
Subject Problem with ISAPI Redirector
Date Thu, 09 Apr 2009 18:54:47 GMT
I'm having a problem using the ISAPI redirector. I making the request, 
and I get back a 400 Bad Request response. I've gone through the 
troubleshooting doc, and the howto for the redirector and come up blank. 
I've also searched the net for the issue.

I'm using version 1.2.27 of the ISAPI redirector (but 1.2.28 does the 
same thing) and Apache Tomcat 5.5.27.

Using the IIS administration program, I created a jakarta virtual 
directory and made it executable. The path points to the directory 
containing the isapi_redirect.dll.

Added the isapi_redirect.dll to the ISAPI Filters for the desired 
virtual host. Added the isapi_redirect.dll to the list of allowed web 
extensions. I'm not getting a Green Up-Arrow on the ISAPI redirect 
filters page. I've done the following:

Made the appropriate registry entries. I'm able to get the log file, so 
I'm confident the registry entries are good.

Set the permissions so that the user the web service runs as has read 
permissions to the configuration directories and write permissions to 
the log directory.

Created the workers.properties:

worker.list=ajp13
worker.ajp13.type=ajp13
worker.ajp13.host=localhost
worker.ajp13.port=8010

Created the uriworkermap.properties:

/calendar/*=ajp13

Configured the server.xml:

<Server port="8006" shutdown="SHUTDOWN">
     <Service name="Catalina">
	<Connector port="7080" />
         <Connector port="8010" protocol="AJP/1.3" />
         <Engine name="Catalina" defaultHost="localhost">
             <Host name="localhost" appBase="webapps">
                 <Logger className="org.apache.catalina.logger.FileLogger"
                                  directory="logs" 
prefix="localhost_log." suffix=".txt"
                             timestamp="true"/>
             </Host>
         </Engine>
     </Service>
</Server>

I've set the level for the isapi log file to debug.

When I make a request for the page:

http://www.heard.org/calendar/ I get the following log output:

http://www.mhsoftware.com/~gsexton/isapi_redirect.log

You can see that it's finding the configuration files, and it's mapping 
the request into the worker but I'm getting a 400 bad request.

About the only thing I notice is that the server has multiple 
application pools set up.

At this point I'm stumped. Does anyone have any ideas on what I can try 
next?


-- 
George Sexton
MH Software, Inc.
Voice: +1 303 438 9585
URL:   http://www.mhsoftware.com/

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message