tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: Tomcat error: It is not available the ServletAction
Date Thu, 02 Apr 2009 14:14:59 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Chuck,

On 4/2/2009 9:08 AM, Caldarale, Charles R wrote:
>> From: bladu [mailto:egoibe@hotmail.com]
>> Subject: Re: Tomcat error: It is not available the ServletAction
> 
> When you send the same message four times, you become extremely annoying - don't do that.

Agreed. I saw one of Bladu's "other" messages first and replied to it
instead of the one that was actually part of this thread, so it's
disconnected, now. I suspect a Xerces version mismatch. His version is
ooooooooold.

>> Do you have xerces.jar in your webapp's lib directory? --->Yes, int he
>> application deployed and also in the WAR I have xerces-1.2.3.jar
> 
> Remove the xerces*.jar from wherever you have it - those classes are
> part of the 1.5 JRE/JDK. Having them in your webapp causes classloading
> confusion.

I disagree. We have applications that provide their own XML parsers and
everything works fine. Apache Cocoon, for instance, ships with
xercesImpl-2.9.1.jar (actual Xerces) along with xml-apis-1.3.04.jar (the
org.w3c.*, org.xml.* and javax.xml.* interfaces, etc.) provided as part
of the webapp's libraries. These work without conflict on Tomcat 5.5.26.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAknUyGMACgkQ9CaO5/Lv0PDQlACgnQBxEedsljyuyUyGv51pt/yu
sQwAoMKYq/Go5An4r9PZHcscn+YJDkxY
=VHUF
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message