tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Schultz <ch...@christopherschultz.net>
Subject Re: Tomcat error: It is not available the ServletAction
Date Thu, 02 Apr 2009 13:59:25 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Bladu,

On 4/2/2009 2:42 AM, bladu wrote:
> Version of Java --->jdk1.5.0_17

Okay.

> Do you have xerces.jar in your webapp's lib directory? --->Yes, int he
> application deployed and also in the WAR I have xerces-1.2.3.jar

OMG that version is like 10 years old. They've been on Xerces 2.x for a
looong time. The current version is 2.9.1. This is likely to be the
problem. Does your application use XML parsing itself and rely on that
old version of Xerces? You may have a problem, then. If you don't do XML
parsing within your own application's code, consider upgrading to a
recent version of Xerces. I'm sure Struts will be a whole lot happier
with that.

> What version of Tomcat are you using?  --->jakarta-tomcat-5.0.28

This version of Tomcat has been abandoned. You should upgrade to 5.5 or
(even better) 6.0 as soon as possible.

- -chris
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAknUxL0ACgkQ9CaO5/Lv0PBBlwCfVfx+8Hj8fnwivOliGsT1pJ9J
tPcAoJe/OtlcPS4BNgue829gcri+SI57
=XQjR
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message