tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Smith <d...@cornell.edu>
Subject Re: Cannot create JDBC driver of class '' for connect URL 'null'Caused by: java.lang.NullPointerException at sun.jdbc.odbc.JdbcOdbcDriver.getProtocol(JdbcOdbcDriver.java:507)
Date Tue, 03 Mar 2009 16:22:21 GMT
Paul Maxted wrote:
> Hello again,
>
> Thanks for your swift responses - apologies for the length of the original, but I see
so many  posts where people immediately ask for more details!
>
> David, I have tried dropping the validation query and I also tried rolling back the version
of  mysql-connector-java to 5.0.8 in case the mismatch between that and the MySQL version
was relevant.
> Neither has changed the outcome.
>
> Any further thoughts?
>
> Regards, Paul
> ________________________________________
>
>   
Don't worry about the length so much.  I'd rather have a post that's a
little long and includes all the relevant details than one of the ever
wonderful "It's broke ... please help me fix it." messages.

Can you look around for other <Context ...></Context> xml fragments that
might be being used instead of the one in your webapp's
META-INF/context.xml?  In particular, see if tomcat's conf directory has
a Catalina/localhost subdirectory or similar with an xml file named
after your webapp.  If it exists, delete it and restart.

Also what Chris said ... although as I remember from the details you
posted, that shouldn't be a problem as your WEB-INF/lib directory was empty.

--David

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message