tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zia mohades <zia.si...@gmail.com>
Subject Re: Apache Tomcat 6.0 loads blank page
Date Wed, 04 Feb 2009 04:45:21 GMT
Hello everyone,

sorry to bug you guys again!

Just to follow up on my last problem. I have re-formatted my whole hard
drive and reinstalled ubuntu from scratch now the tomcat apache runs
perfectly and i can access http://localhost:8080/mms_test/index.html with no
problem.

However the same problem still remains one of my html file located in
/usr/local/tomcat/webapps/mms_test must access a cgi file calld test.cgi(
located in /usr/local/tomcat/bin). however when I click on the button in the
hesearch.html file using

<form name="mainform" method="get" action="../../bin/test.cgi">

 It gives me this error:

HTTP Status 404 - /bin/test.cgi
------------------------------

*type* Status report

*message* */bin/test.cgi*

*description* *The requested resource (/bin/test.cgi) is not available.*
------------------------------
Apache Tomcat/6.0.18

I don't undrestand what the problem is?????

1) I have gave all the permissions to test.cgi file
2) this is the address i use ../../bin/test.cgi and it seems to me the right
addres.


please let me know what I am doing wrong. Do i need to put test.cgi in a
different directory?? I don't have a cgi-bin directory only "bin" directory,
is that my problem???

your help is really appreciate , since my master project is based on this!
:(

thank u kindly for your help

zia


On Sun, Feb 1, 2009 at 6:14 PM, Martin Gainty <mgainty@hotmail.com> wrote:

>
> you'll need to create a startup index page called index.jsp which will be
> located in webapps/YourWebAppName
>
> then configure ./WEB-INF/web.xml to load initial display
>    <welcome-file-listing>
>     <welcome-file>index.jsp</welcome-file>
>    </welcome-file-listing>
>
> HTH
> Martin
> ______________________________________________
> Disclaimer and confidentiality note
> Everything in this e-mail and any attachments relates to the official
> business of Sender. This transmission is of a confidential nature and Sender
> does not endorse distribution to any party other than intended recipient.
> Sender does not necessarily endorse content contained within this
> transmission.
>
>
>
>
> > From: brae39@gmail.com
> > To: users@tomcat.apache.org
> > Subject: RE: Apache Tomcat 6.0 loads blank page
> > Date: Sun, 1 Feb 2009 12:59:19 -0800
> >
> > I am new to Tomcat as well... But, does mms_test contain WEB-INF with
> > web.xml, like other directories under webapps do? Try copy it from "docs"
> > and see what happens. Also, if you pull mms_test out of webapps and
> restart
> > tomcat, does the problem go away? Did you change server.xml from the
> > default?
> >
> > Hope this helps.
> > Qiao
> >
> > -----Original Message-----
> > From: zia mohades [mailto:zia.simab@gmail.com]
> > Sent: Sunday, February 01, 2009 11:24 AM
> > To: Tomcat Users List; p@pidster.com
> > Subject: Re: Apache Tomcat 6.0 loads blank page
> >
> > Hello all,
> >
> > Thank you keshave for your answer. In fact my folder mms_test is already
> in
> > teh webapps directory and when I try accessing it using
> > http://localhost:8080/mms_test/index.html or just
> > http://localhost:8080/mms_test/. I get the same thing "blank page"
> nothing
> > is displayed. I am not sure what I need to do.
> >
> > P, in response to your email, my folder is in mms_test not in root,
> should i
> > place it in root? also I am not sure exactly what you meant by
> > "'META-INF/context.xml'" because i don't have any directory called
> "META-INF
> > in webapps do i need to creat it? the context.xml is currently located in
> > /usr/local/tomcat/conf.
> >
> > I am getting a bit frustated here, I definitely appreciate your help with
> > this. also one more this i should mention, when restart the server couple
> of
> > times using
> >  sudo /etc/init.d/tomcat restart
> >
> > I get this message:
> > Using CATALINA_BASE:   /usr/local/tomcat
> > Using CATALINA_HOME:   /usr/local/tomcat
> > Using CATALINA_TMPDIR: /usr/local/tomcat/temp
> > Using JRE_HOME:       /usr/lib/jvm/java-6-sun
> > 1-Feb-2009 2:22:58 PM org.apache.catalina.startup.Catalina stopServer
> > SEVERE: Catalina.stop:
> > java.net.ConnectException: Connection refused
> >     at java.net.PlainSocketImpl.socketConnect(Native Method)
> >     at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
> >     at
> java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
> >     at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
> >     at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
> >     at java.net.Socket.connect(Socket.java:519)
> >     at java.net.Socket.connect(Socket.java:469)
> >     at java.net.Socket.<init>(Socket.java:366)
> >     at java.net.Socket.<init>(Socket.java:180)
> >     at org.apache.catalina.startup.Catalina.stopServer(Catalina.java:421)
> >     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
> >     at
> >
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39
> > )
> >     at
> >
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl
> > .java:25)
> >     at java.lang.reflect.Method.invoke(Method.java:597)
> >     at
> org.apache.catalina.startup.Bootstrap.stopServer(Bootstrap.java:337)
> >     at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:415)
> > Using CATALINA_BASE:   /usr/local/tomcat
> > Using CATALINA_HOME:   /usr/local/tomcat
> > Using CATALINA_TMPDIR: /usr/local/tomcat/temp
> > Using JRE_HOME:       /usr/lib/jvm/java-6-sun
> >
> > But it doesn't change the problem: blank page again when I try to access
> > http://localhost:8080/mms_test/
> >
> > Your help is greatly appreciated
> >
> > thank u kindly
> >
> > zia
> >
> >
> >
> >
> > On Sun, Feb 1, 2009 at 7:34 AM, Pid <p@pidster.com> wrote:
> >
> > > zia mohades wrote:
> > > > Hi there,
> > > >
> > > > I am currently having issue loading my own page using tomcat apache
> 6.0
> > > on
> > > > ubuntu, here are the details;
> > > >
> > > > 1) when I start the server using sudo /etc/init.d/tomcat restart and
> > then
> > > > try to access the server via http://localhost:8080, i sucessfully
> > > > get the welcome page and the logo of the tomcat
> > > >
> > > > 2) I then place my own folder called mms_tets( containing html files)
> in
> > > > /usr/local/tomcat/webapps and then restart the server using the same
> > > > command. however when try to access the http://localhost:8080 i get
> a
> > > blank
> > > > page. Showing absolutely nothing and I don't even get any errors. I
> > > checked
> > > > the permission also and it seems like I gave the full permission:
> > > > drwxrwxrwx  9 mohadesz mohadesz 4096 2009-01-31 21:13 mms_test
> > > >
> > > >  I also checked the log folder , and here are their results:
> > > >
> > > > for  catalina.2009-01-31.log --> 31-Jan-2009 9:34:46 PM
> > > > org.apache.catalina.startup.Catalina start
> > > > INFO: Server startup in 1520 ms
> > > >
> > > > for localhost.2009-01-31.log  -->31-Jan-2009 9:34:46 PM
> > > > org.apache.catalina.core.ApplicationContext log
> > > > INFO: SessionListener: contextInitialized()
> > >
> > > If you're trying to make your app the ROOT app, then you need to call
> > > the directory it's in 'ROOT' or name it ROOT.war (if it's a compressed
> > > war file).
> > >
> > > If you have the Context defined in server.xml, you should instead place
> > > the definition in a file inside your webapp 'META-INF/context.xml'.
> > > Do not use the 'path' or 'docbase' attributes. and
> > >
> > >
> > > p
> > >
> > >
> > >
> > > > i definitely appreciate your help! I spent so much time on this and
> > > > seriously can't figure out the problem.
> > > >
> > > > Thank you kindly
> > > >
> > > >
> > > > zia
> > > >
> > >
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > > For additional commands, e-mail: users-help@tomcat.apache.org
> > >
> > >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> > For additional commands, e-mail: users-help@tomcat.apache.org
> >
>
> _________________________________________________________________
> Hotmail(R) goes where you go. On a PC, on the Web, on your phone.
>
> http://www.windowslive-hotmail.com/learnmore/versatility.aspx#mobile?ocid=TXT_TAGHM_WL_HM_versatility_121208
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message