tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zia mohades <zia.si...@gmail.com>
Subject Re: Apache Tomcat 6.0 loads blank page
Date Mon, 02 Feb 2009 15:29:59 GMT
Hi everyone,

Chuck, I just double checked the web.xml and the following:

   <welcome-file-list>
        <welcome-file>index.html</welcome-file>
        <welcome-file>index.htm</
>
> welcome-file>
>         <welcome-file>index.jsp</welcome-file>
>    </welcome-file-list>
>
is in fact there. And Also i restarted the apache server couple of time and
now I can access the web server using
http://localhost:8080/mms_test/index.html directly, w/o having to use
index.jsp.

Andre, for the questions you asked

1) for the connector port I have commented out one of them actually, so only
two of them are active these ones:

 <Connector port="8080" protocol="HTTP/1.1"
              connectionTimeout="20000"
              redirectPort="8443" />
   <!-- A "Connector" using the shared thread pool-->


   <Connector port="8080" protocol="HTTP/1.1" SSLEnabled="true"
              maxThreads="150" scheme="https" secure="true"
              clientAuth="false" sslProtocol="TLS" />


2)  for the LiveHttpHeader,I just tried it again. and now it works in fact
this is what I get:


http://localhost:8080/bin/test.cgi?searchvalue=asdfsdf&searchtype=sequence&option=Beta+sheets+Database+Only&length=3

GET
/bin/test.cgi?searchvalue=asdfsdf&searchtype=sequence&option=Beta+sheets+Database+Only&length=3
HTTP/1.1
Host: localhost:8080
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5)
Gecko/2008121621 Ubuntu/8.04 (hardy) Firefox/3.0.5
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-us,en;q=0.5
Accept-Encoding: gzip,deflate
Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive: 300
Connection: keep-alive
Referer: http://localhost:8080/mms_test/hesearch.html

HTTP/1.x 404 Not Found
Server: Apache-Coyote/1.1
Content-Type: text/html;charset=utf-8
Content-Length: 991
Date: Mon, 02 Feb 2009 15:25:20 GMT

3) however now i have a new problem: for some reason my html page doesn't
communicate with the cgi file.
"hesearch.html" in /usr/local/tomcat/webapps/mms_test , doesn't communicate
with the cgi program test.cgi located in /usr/local/tomcat/bin.
hesearch.html contains a button which when it is pushed it accesses the
test.cgi which executes other programs. However when i push that button , i
get this error:

" HTTP Status 404 - /bin/test.cgi
------------------------------

*type* Status report

*message* */bin/test.cgi*

*description* *The requested resource (/bin/test.cgi) is not available.*

*
************************************************************************************************
*

However the program is in the right location and i have all the permissions.


any suggestions?


Thank you again for all your helps,


regards


zia






On Mon, Feb 2, 2009 at 12:25 AM, Caldarale, Charles R <
Chuck.Caldarale@unisys.com> wrote:

> > From: zia mohades [mailto:zia.simab@gmail.com]
> > Subject: Re: Apache Tomcat 6.0 loads blank page
> >
> > perfect! thank you martin, I have just created a JSP file,
> > index.jsp and copied the content of index.html into it. and
> > then made this  modification as you said:
>
> None of which you should have to do.  A real Tomcat download (from
> tomcat.apache.org) includes a default web.xml in Tomcat's conf directory
> that already contains the following:
>
>    <welcome-file-list>
>         <welcome-file>index.html</welcome-file>
>         <welcome-file>index.htm</welcome-file>
>         <welcome-file>index.jsp</welcome-file>
>    </welcome-file-list>
>
> It sounds like yours doesn't have that, so I would strongly suggest
> removing the Ubuntu version of Tomcat and installing a real one from the
> above web site.  We've had innumerable strange problems with 3rd-party
> repackaged versions of Tomcat that do not occur with the real one.
>
>  - Chuck
>
>
> THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
> MATERIAL and is thus for use only by the intended recipient. If you received
> this in error, please contact the sender and delete the e-mail and its
> attachments from all computers.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message