tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From zia mohades <zia.si...@gmail.com>
Subject Re: Apache Tomcat 6.0 loads blank page
Date Sun, 01 Feb 2009 22:08:30 GMT
Hi again:

Andre thank you for your email:

1) when I check the logs I see the follwoing

   for localhost logs :1-Feb-2009 4:16:04 PM
org.apache.catalina.core.ApplicationContext log
INFO: SessionListener: contextInitialized()

   for catalina logs:  I have this:
1-Feb-2009 5:01:42 PM org.apache.tomcat.util.digester.Digester fatalError
SEVERE: Parse Fatal Error at line 71 column 8: Comment must start with
"<!--".
org.xml.sax.SAXParseException: Comment must start with "<!--".
    at
com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.createSAXParseException(ErrorHandlerWrapper.java:195)
    at
com.sun.org.apache.xerces.internal.util.ErrorHandlerWrapper.fatalError(ErrorHandlerWrapper.java:174)
    at
com.sun.org.apache.xerces.internal.impl.XMLErrorReporter.reportError(XMLErrorReporter.java:388)
    at
com.sun.org.apache.xerces.internal.impl.XMLScanner.reportFatalError(XMLScanner.java:1411)
    at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.startOfMarkup(XMLDocumentFragmentScannerImpl.java:2577)
    at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2695)
    at
com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:648)
    at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510)
    at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:807)
    at
com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
    at
com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:107)
    at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1205)
    at
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
    at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1644)
    at org.apache.catalina.startup.Catalina.load(Catalina.java:516)
    at org.apache.catalina.startup.Catalina.start(Catalina.java:570)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
1-Feb-2009 5:01:42 PM org.apache.catalina.startup.Catalina load
WARNING: Catalina.start using conf/server.xml:
org.xml.sax.SAXParseException: Comment must start with "<!--".
    at
com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1231)
    at
com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl$JAXPSAXParser.parse(SAXParserImpl.java:522)
    at org.apache.tomcat.util.digester.Digester.parse(Digester.java:1644)
    at org.apache.catalina.startup.Catalina.load(Catalina.java:516)
    at org.apache.catalina.startup.Catalina.start(Catalina.java:570)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
1-Feb-2009 5:01:42 PM org.apache.catalina.startup.Catalina start
INFO: Server startup in 0 ms

   but again, I can successfully access http://localhost:8080 and blank for
http://localhost:8080/mms_test. so the log files are not very informative.

2) I have downloaded LiveHttpHeaders plugin and followed your instructions.
Believe it or not when I access http://localhost:8080/mms_test or
http://localhost:8080 or http://localhost:8080/mms_test , and when i click
on "Live http headers" form tools , the headers are empty. However when I
access any other sites , like google , the headers has info in it( as it is
expected)

Sooo I am seriously confused and frustated!!! I just dont know what to do!!

I even tried http://localhost:8080/mms_test/index.html but same problem :(

sorry again for the hassell but seriously any solution is appreciated!


thank you kindly

zia



On Sun, Feb 1, 2009 at 4:45 PM, André Warnier <aw@ice-sa.com> wrote:

> zia mohades wrote:
>
>> Hello again,
>>
>> Qiao thank you for your help. I tried copying the WEB-INF(which includes
>> web.xml) to mms_test but the problem is still there( blank page). I tried
>> copying the mms_test somewhere else like to ROOT, but the problem still
>> remains.  Just to let you know I can successfull view the page
>> http://localhost:8080/ but get a blank page when try to access the
>> http://localhost:8080/mms_test/
>>
>>  And when you try that second link, and you get the blank page, is there
> anything in your Tomcat logs ?
>
> I mean, when you try to access http://localhost:8080/mms_test/, there are
> only a limited number of possibilities :
> - either your browser cannot reach the server.  Then you would get a
> browser message saying "cannot reach the server". You don't get that, so we
> assume the browser can reach Tomcat.
> - or the browser reaches the server, and the server cannot find the
> requested page (or application), or it cannot access it (permission
> problem), or there is an error in the application.  Then you would get an
> error page from Tomcat.  But you do not get that.
> - so we have to assume that Tomcat finds "something", and is sending it
> back to the browser.  That something seems to be an empty page.
> But it certainly comes at least with some HTTP Headers from Tomcat.
>
> If there is nothing in the Tomcat logs :
> If you are using Firefox as a browser (recommended), get and install the
> LiveHttpHeaders plugin. Here :
> https://addons.mozilla.org/en-US/firefox/addons/versions/3829
>
> That is a plugin that allows you to see the HTTP Headers that the webserver
> is sending along with the response (the blank page).
> (If IE, get a similar plugin (Fiddler2 ?).)
> Anyway, activate the plugin (in Firefox, LiveHttpHeaders appears in the
> Tools menu, just click on it. It opens its own window).
> Then just go back to the main window, call up your mmtest link, and look in
> the LiveHttpHeaders window, what exactly the server sent.
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message