tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From AD <straightfl...@gmail.com>
Subject Re: failed ActiveMQ hangs tomcat
Date Sun, 01 Feb 2009 05:08:58 GMT
actually i think i did notice failover() with only 1 address in
non-prod.  I think the reason that was there was some config
templating issue.

Are you saying if you remove the failover and just go straight in this
might resolve it?

Will give it a shot

Adam

On Sun, Feb 1, 2009 at 12:05 AM, Kirk True <kirk@mustardgrain.com> wrote:
> Hi Adam,
>
> AD wrote:
>>
>> hello,
>>
>>  i am running into a situation where if our JMS server is down
>> (activemq) the tomcat application does not respond at all.  Not sure
>> why tomcat is relying so heavily on this connection , any ideas as to
>> why this would be ?
>>
>>
>
> Does your ActiveMQ connection URL include the failover:// prefix? I've seen
> applications hang near-indefinitely trying to fail over to the same (downed)
> ActiveMQ server over and over again.
>
> One way to see where the actual hang is would be to get a thread dump. The
> standard 'kill -3 <pid>' of the Tomcat process (on Linux/UNIX) would do the
> trick.
>
> This sounds more like a web application issue than an issue with Tomcat.
> Also, if you have integration tests that connect to a live JMS server you
> could experiment with 'pulling the cord' and see where it hangs. This would
> then remove Tomcat from the equation.
>
> Kirk
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message