tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: very slow class loading on initial JSP/servlet request afterrestart
Date Wed, 25 Feb 2009 20:57:05 GMT
Caldarale, Charles R wrote:
>> From: Sam Hokin [mailto:sam@ims.net]
>> Subject: Re: very slow class loading on initial JSP/servlet
>> request afterrestart
>>
>> http://www.ims.net/media/strace-test6-stall.txt
> 
> So what's going on during the frequent 11-second gaps?  (Was Rosemary Woods here?)

They are not only frequent, they are also totally regular.  Looks like a 
regular gap of 10 s + some fraction, that looks like 10 or 11 just 
because of the logfile stamp resolution.


> 
> Might want to redo the strace with the -T option to show the time spent inside each system
call.
> 
>> During the Tomcat stall phase there are thousands
>> and thousands of stat64, access, lstat64 calls to
>> the same class files (and directories above those
>> files) across pages on all four sites.

Actually it is totally regular : stat, access, lstat, stat, then 10.xxx 
delay, then again stat, access, lstat, stat, 10 seconds +.
What in this directory path is (are) a symlink(s) ?
/home/sites/ims/jcms/webapps/ROOT/WEB-INF/classes/org/apache/jsp/test6_jsp.class
and to what does it (they) point ?
And how is this different from the other 2 systems that work fine ?



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message