tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sam Hokin <...@ims.net>
Subject Re: very slow class loading on initial JSP/servlet request after restart
Date Fri, 20 Feb 2009 16:02:42 GMT
Caldarale, Charles R wrote:

> 1) What are the servers that don't have a problem?

One is a single AMD Athlon 64 2800+, running the 64-bit Sun JDK (same version).

The other is a dual AMD Athlon MP 2000+, running the 32-bit Sun JDK (same version).

And the "bad" server has "8" Intel Xeon E5310 CPUs running the 32-bit Sun JDK (it is indeed
a dual quad-core, not a quad 
dual-core, as I incorrectly typed in my original post).

> 2) How much RAM is on each server?

The Athlon 64 has 1.5 GB RAM (2 GB swap).
The dual 32-bit Athlon has 1 GB RAM (2 GB swap).
The "bad" server has 2 GB RAM (2 GB swap).

> 3) Is the JDK 32- or 64-bit on each server?

32-bit on the two 32-bit machines, 64-bit on the 64-bit machine.

> 4) What's the Java heap size for Tomcat on each server?

I've played with heap size quite a bit to no avail.   Currently, all are running 768 MB with
the following JDK options:

JAVA_OPTS="-Xms768m -Xmx768m -XX:NewSize=256m -XX:MaxNewSize=256m -XX:PermSize=128m -XX:MaxPermSize=128m"

> 5) Are you using the same file system on all three servers?  What is it (ext3, reiser,
???)?

Yes.  ext3 on all three machines, all are running current Fedora Core 9 distros (well, except
for the new kernel which 
came out yesterday).

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message