tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "denis.r" <denis.rac...@hp.com>
Subject Re: Enabling CGI in Tomcat 6 affect all webapps.
Date Tue, 24 Feb 2009 06:03:00 GMT



Mark Thomas-18 wrote:
> 
> denis.r wrote:
>>> Hi,
>>> I followed the instructions on how to enable CGIs in Tomcat 6 found at:
>>> http://tomcat.apache.org/tomcat-6.0-doc/cgi-howto.html . This works fine
>>> for
>>> my webapp that has a CGI, but unfortunately it affects ALL my webapps
>>> within
>>> the container. Even those that don't have CGIs. The webapps that don't
>>> have
>>> CGIs now get errors claiming they must set privileged in order to use
>>> CGIServlet, even though they aren't using CGIServlet. Is there any way
>>> to
>>> turn this on just for the webapp using CGIs?
> 
>> Move the CGIServlet definition and mapping from the global web.xml
>> (CATALINA_BASE/conf/web.xml) to your web application's web.xml.
> 
>> Mark
> 
> Moving the config to the application's web.xml did the trick. Thank you.
> It would be great if the documentation suggested this instead of modifying
> the global config. In fact it should be the standard way to do it. Now
> that you suggested it, it makes perfect sense. I only want this enabled
> for web apps that have CGIs defined, not the entire container.
> 
> Denis
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Enabling-CGI-in-Tomcat-6-affect-all-webapps.-tp22161635p22176403.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message