tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: tomcat webapp FORM authentication problem
Date Wed, 25 Feb 2009 03:13:50 GMT
> From: Alexander Soudackov [mailto:souda@chem.psu.edu]
> Subject: tomcat webapp FORM authentication problem
>
> I have a very annoying problem with a secured folder
> in my tomcat web application.

You could start the problem description by telling us the version of Tomcat you're using.
 It's likely not pertinent for this particular issue, but it's annoying to hide such information.

> The problem #1 is: login.html displays a form BUT there
> is NO images, NO CSS formatting, and Javascript!

Think about it: you've declared the resources noted as being protected, authentication has
not occurred, yet somehow you're expecting Tomcat to magically ignore the protection settings
when the browser requests these resources?  You can't have it both ways - you need to place
the resources the form needs outside of the protected area.

> The problem #2 is: after successful authentication the
> browser shows the SOURCE of the first javascript referenced
> in index.html, instead of index.html

Try fixing the first problem and see if the second one disappears.

> The problems reoccur after cleaning the cash and cookies of
> the browser.

You robbed your browser?  Or did you clean out its cache?

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message