tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Ubuntu 8.10 GWT Apache2 Tomcat Servlet Problems
Date Wed, 18 Feb 2009 19:05:27 GMT
> From: Scott Carlson [mailto:scarlson@i2s.com]
> Subject: Re: Ubuntu 8.10 GWT Apache2 Tomcat Servlet Problems

> That was what I had originally, it has changed often due to
> conflicting advice on forums. I did change it back to test.

Leave it as is, without the package name.  The <url-pattern> must match... the URL pattern
(what a coincidence).  If you're not using com.i2s.webMonster.server as part of the URL, it
shouldn't be in the <url-pattern>.  (Whatever forum advised including the package name
is a forum to avoid.)

> 127.0.0.1 - - [18/Feb/2009:13:46:39 -0500] "POST
> /webMonster/MsgService HTTP/1.1" 500 2656 0.004 -

The above is the only one of interest in the access log.  As previously suggested, test with
just this URL, using wget or equivalent, direct to Tomcat; eliminate the rest of the crap
until the servlet is sorted.

> SEVERE: Allocate exception for servlet MsgService
> java.lang.ClassNotFoundException:
> com.i2s.webMonster.server.MsgServiceImpl

Perhaps you need to fix the above before doing anything else.

> I haven't seen that latter log until just now! Does this help?

In the word of Homer Simpson, Doh!

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message