tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From János Löbb <janos.l...@yale.edu>
Subject some config issue with Apple supplied Tomcat
Date Mon, 12 Jan 2009 21:26:47 GMT
Hi,

I am trying to setup a cluster using Apple supplied Apache2 and  
Tomcat.  On OSX, tomcat is in /Library/Tomcat.

Apache is configured in a mixed way, because Apple installs 1.3 and  
2.2, so there is /etc/httpd for config of 1.3 and /etc/apache2 for  
config of 2.2.  However even the config file in /etc/apache2 refers to  
the workers.properties in /etc/httpd :)  Looks like as siamese twins  
in the process of separation.

Tomcat version 6.0.18

Java:
java version "1.5.0_16"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16- 
b06-284)
Java HotSpot(TM) Server VM (build 1.5.0_16-133, mixed mode)

apache2:  version 2.2

Tomcat is running after checking the checkbox and restarting Apache2
pathsrv1:httpd administrator$ ps -avx |grep tomcat
59195 Ss     0:01.10   0   0      0   600172    628     -        0    
0.0  0.0 /bin/sh /Library/Tomcat/bin/tomcat-launchd.sh
62573 R+     0:00.00   0   0      0   590472     92     -        0    
0.0  0.0 grep tomcat

and I can get to the SessionExample via port 80.

However I get this into the mod_jk.log:
[Mon Jan 12 14:57:31 2009] [59281:0000] [error] init_jk::mod_jk.c  
(2701): Initializing shm:/usr/logs/jk-runtime-status.59281 errno=2.  
Load balancing workers will not function properly.

Looking on the Internet someone recommended to create a "run"  
directory, that used to be in /usr/local/apache2/.  I do not know if  
that is the solution for this Apple supplied config on OSx 10.5.6.


I also have a second issue, but that might relate to this message  
above.  I created a reverse proxy setup and this is what Apple put  
into the site configuration file:

         <IfModule mod_proxy_balancer.c>
                 ProxyPass /apps/ balancer://balancer-group/  
stickysession=JSESSIONID
                 ProxyPassReverse /apps/ balancer://balancer-group/
                 <Proxy "balancer://balancer-group">
                         BalancerMember http://pathsrv1.yalepath.org  
loadfactor=1
                 </Proxy>
         </IfModule>

Right now I have just one machine and I am trying it as a Balance  
member and also as a reverse proxy.  So based upon the config, I  
thought that if I want to go to;

http://pathsrv1.yalepath.org/apps/examples/servlets/servlet/SessionExample

than the reverse proxy that is pathsrv1 will pass it to the balance  
member, that is again pathsrv1 and from there It will give me the  
SessionExample as if I would have gone just to

http://pathsrv1.yalepath.org/examples/servlets/servlet/SessionExample

Either my config is not right, or my thinking :)

Any good hint is appreciated.

János


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message