tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: Specific Tomcat version for Java6
Date Thu, 29 Jan 2009 10:48:33 GMT
Caldarale, Charles R wrote:
>> From: Christopher Schultz [mailto:chris@christopherschultz.net]
>> Subject: Re: Specific Tomcat version for Java6
>>
>> No. I believe all versions of Tomcat can be run on all
>> versions of Java from 1.2 onward
> 
> Don't think so.  Tomcat 6 requires Java 1.5 or newer (seems to work happily even on the
1.7 beta).

> I'm also pretty certain you can't run 5.5 on a 1.3 JVM, but I haven't actually tried
it.
Correct. You might be able to get it to work with lots of extra libs and some
tweaks to the source.

> Don't know about the 4.x Tomcat levels.
Most of Tomcat 4 will run on a 1.2 JVM. Some things don't work, the CGI serv;et
being one of them if I recall correctly.

To get back to the original question, Tomcat 7 which will implement the servlet
3.0 spec will require a 1.6 JVM (as required by the spec). So far there are a
few generics tweaks in 1.6 we are taking advantage of but no major usage of 1.6
features. That may well change as development progresses.

Mark

> 
>  - Chuck
> 
> 
> THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and
is thus for use only by the intended recipient. If you received this in error, please contact
the sender and delete the e-mail and its attachments from all computers.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message