tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ani <jadhao.anirud...@gmail.com>
Subject Re: Tomcat 6.0 loading servlet twice
Date Thu, 29 Jan 2009 06:18:46 GMT
>
>
>
> On Thu, Jan 29, 2009 at 11:40, Ani <jadhao.aniruddha@gmail.com> wrote:
>
>> Hello,
>> I have a web application in which I am facing one wiered pbm. I see tomcat
>> loading servlet twice , on which my application logic is failing and quits.
>> Getting below error in log file.
>> My findings : One thing I did was , inside comp folder I made a copy of
>> website folder and renamed it to website_old. Now both folders contains
>> servlet.jar. Will it be causing a pbm???
>> ==========================================================
>> Jan 29, 2009 10:48:34 AM org.apache.catalina.loader.WebappClassLoader
>> validateJarFile
>> INFO: validateJarFile(.\comp\website_old\WEB-INF\lib\servlet.jar) - jar no
>>
>> t loaded. See Servlet Spec 2.3, section 9.7.2. Offending class:
>> javax/servlet/Servlet.class
>> ==========================================================
>>
>>
>> I have
>> Server.xml has an entry of below
>>
>> <Context docBase="C:\Program Files\Avaya/comp/website" path="/website"
>> reloadable="false" crossContext="true" />
>>
>> So tomcat should look for website folder in the specified directory, but
>> in the C:\Program Files\Avaya/comp directory, there are two directories ,
>> website and website_old.
>> Why tomcat is searching for C:\Program Files\Avaya/comp/website_old
>> application if it gets the C:\Program Files\Avaya/comp/website . ??
>> I have tomcat6.
>>
>> Any reason??
>> --Ani
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message