tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Troy Davidson" <Troy.David...@maverik.com>
Subject Tomcat Not Releasing URL Connection
Date Tue, 30 Dec 2008 19:03:11 GMT
Hello,

I've searched for an answer to this problem, but haven't found anything yet.

Here is the problem:

I have an application that connects to a 3rd party vendors server to request updated information.
 This connection is created and closed in the Java code each time it is needed.  This works
fine and the new data is pulled.

But, if the 3rd party vendor's server goes down and they switch to their backup server, my
Java code never gets any data.  I can go into Tomcat and restart the Java app, but it still
won't receive new data.  If I restart Tomcat, then, I will start to get new data.  

I have racked my brain about this for a while and just can't come up with any answers.  It
seems that Tomcat is pooling the network connection and not releasing it but reusing it each
time.  I would assume this is for speed, but when the servers switch, I need a way to tell
Tomcat to release the connection and make a new one.

I hope this makes sense and someone else has seen a similar, if not the same, problem.

Setup Info:
Tomcat 6.0.18
java-1_5_0-ibm-1.5.0_sr8 (The hardware team set this up, so I assume the IBM JVM was all that
was available.)
SUSE (SLES) 10

Any help would be great.  Thanks.

Troy Davidson
Senior Programmer
 
Maverik, Inc.
880 W. Center St.
NSL, Utah 84054
 
801-335-3887 Office
801-663-1460 Cell
 
Thank you for allowing us to service your technical needs,
Your Technical Services Team



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message