tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mikko Pukki <Mikko.Pu...@syncrontech.com>
Subject RE: Multiple IIS sites and ISAPI redirect problem
Date Wed, 05 Nov 2008 14:56:17 GMT
Thanks for your reply.

I double checked the rights for configuration files but they seemed ok. I only added
read&execute rights for Local Service in addition to already configured
Network service etc. I also renamed workers.properties.minimal to workers.properties
and changed the configuration in Windows' Register accordingly. Name of the file was
configured correctly to register before so I quess it did not make a difference.

Only other (real) change that I made was an update from 1.2.26 to 1.2.27.
Once I started site again, everything worked as a charm. So it could be the update
that helped. No idea why, and I have no chance to really confirm this, because the
site is not mine (it is client's) and it is in production use, so I cant fiddle around
with it.

For all other people that answered:
You could read the whole email from start to end, so you could save yourself from making
unnecessary questions (whitch are really already answered in the mail) for the list.
Or is this the common behavior on users@tomcat?


Best regards,
  Mikko

-----Original Message-----
From: Rainer Jung [mailto:rainer.jung@kippdata.de] 
Sent: 24. lokakuuta 2008 20:11
To: Tomcat Users List
Subject: Re: Multiple IIS sites and ISAPI redirect problem

Mikko Pukki schrieb:
> Hi,
> 
> I have Tomcat installed on a server that already has "Default Website" configured for
other use and I cannot use
> it to redirect to Tomcat. So I created another website that should listen to port 80
and authenticate users via AD authentication.
> After authentication it should redirect requests to Tomcat. Previously I have done such
installations with one difference.
> I have been able to use "Default Website" and  generally there have been little or no
problems.
> 
> However with this installation it doesn't work. System is Windows Server 2003, IIS version
is 6, tomcat version is 5.5.16,
> ISAPI redirect version is 1.2.26. I did not use compatibility mode for IIS 5 and first
I got 404 (or maybe 403 or something)
> from IIS, but I figured out that it was because of rights to read and execute dll. I
corrected them and now IIS returns
> internal server error. Both Tomcat and ISAPI redirect filter start ok. Filter has a green
arrow in front of it and I can use
> web application directly from port 8080.
> 
> All that appears on ISAPI redirctor's log on debug level is as follows:
> 
> [Tue Oct 07 15:45:52.843 2008] [6728:6948] [debug] jk_util.c (430): Pre-processed log
time stamp format is '[%a %b %d %H:%M:%S.000 %Y] '
> [Tue Oct 07 15:45:52.843 2008] [6728:6948] [debug] jk_shm.c (169): Initialized shared
memory size=28800 free=28672 addr=0x1eb0000
> [Tue Oct 07 15:45:52.843 2008] [6728:6948] [debug] jk_isapi_plugin.c (1688): Using registry.
> [Tue Oct 07 15:45:52.843 2008] [6728:6948] [debug] jk_isapi_plugin.c (1691): Using log
file C:\foo\Tomcat\isapi\log\isapi_redirect.log.
> [Tue Oct 07 15:45:52.843 2008] [6728:6948] [debug] jk_isapi_plugin.c (1692): Using log
level 1.
> [Tue Oct 07 15:45:52.843 2008] [6728:6948] [debug] jk_isapi_plugin.c (1693): Using extension
uri /jakarta/isapi_redirect.dll.
> [Tue Oct 07 15:45:52.843 2008] [6728:6948] [debug] jk_isapi_plugin.c (1694): Using worker
file C:\foo\Tomcat\conf\workers.properties.minimal.
> [Tue Oct 07 15:45:52.843 2008] [6728:6948] [debug] jk_isapi_plugin.c (1695): Using worker
mount file C:\foo\Tomcat\conf\uriworkermap.properties.
> [Tue Oct 07 15:45:52.843 2008] [6728:6948] [debug] jk_isapi_plugin.c (1697): Using rewrite
rule file .
> [Tue Oct 07 15:45:52.843 2008] [6728:6948] [debug] jk_isapi_plugin.c (1699): Using uri
select 3.
> 
> 
> So it starts ok? At lest it shows that keys in registery are correct; right property
files are found and debug level is on. Should I see some more output here?

Yes, it should proceed similar to this:

[Fri Oct 24 18:53:14.203 2008] [2536:14028] [debug] jk_map.c (492):
Adding property '/*' with value 'wlb' to map.
[Fri Oct 24 18:53:14.203 2008] [2536:14028] [debug] jk_map.c (492):
Adding property '/jkmanager' with value 'jkmanager' to map.
[Fri Oct 24 18:53:14.203 2008] [2536:14028] [debug] jk_uri_worker_map.c
(722): Loading urimaps from C:\foo\Tomcat\conf\uriworkermap.properties
with reload check interval 60 seconds

And later on lots of additional messages during startup but also for
each request.

I can produce the same behaviour (logging stops to early and forwarding
doesn't work), when I rename my uriworkermap.properties file. So please
double check, that the file is there under the correct name, and that
IIS can read it.

> For example GET messages? Anyway that's all that filter outputs.
> 
> Content of workers.properties.minimal:
> 
> worker.list=wlb,jkstatus
> worker.ajp13w.type=ajp13
> worker.ajp13w.host=localhost
> worker.ajp13w.port=8009
> 
> worker.wlb.type=lb
> worker.wlb.balance_workers=ajp13w
> 
> worker.jkstatus.type=status
> 
> Content of uriworkermap.properties:
> 
> /*=wlb
> /jkmanager=jkstatus

Looks OK as a vry basic configuration.

> Same configuration files have previously (and still do) worked well with othes servers,
so I have no reason to doubt that they are to blame.
> Any idea what would be causing the behavior? Is the Isapi Filter supposed to be cinfigured
for a spesific website if I do have multiple
> websites? Or should it be configured for upper level ("WebSites"), or is this kind of
configuration supposed to work in the first place?

I have it working like you configured it.

> I quess that IIS finds the filter ok, because first when rights for filter were incorrect,
I got different error message than now. Any Ideas?

You also need to allow the extension in the lowest GUI item of the IIS
configuration window.

Regards,

Rainer


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message