tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Albretch Mueller" <lbrt...@gmail.com>
Subject Re: BUILD FAILED ...
Date Wed, 26 Nov 2008 23:35:09 GMT
On Wed, Nov 26, 2008 at 4:08 PM, Caldarale, Charles R
<Chuck.Caldarale@unisys.com> wrote:
>> sh-3.1# java -version
>> java version "1.6.0_07"
>
> Tomcat must be built with a 1.5 JDK at the moment, due to incompatibilities introduced
by Sun in 1.6.
~
 However, tc doc states: "version 1.5.x or later" and to me "later"
meant 1.6.0_07 should be fine
~
> Looks like you skipped the "ant download" part.
~
 I think the jdk version issue would have made it fail anyway
~
>
> For curiosity's sake, why are you bothering to build Tomcat?
~
 I like to keep the source baseline of anything I use for production
(well, anything anyway)
~
 After doing the changes you suggested I got a "NoClassDefFoundError",
when I tried to run it:
~
sh-3.1# sh ./catalina.sh run
Using CATALINA_BASE:   /media/hda3/tc/tc-6.0.18
Using CATALINA_HOME:   /media/hda3/tc/tc-6.0.18
Using CATALINA_TMPDIR: /media/hda3/tc/tc-6.0.18/temp
Using JRE_HOME:       /media/hda3/jdk1.5.0_16
Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/catalina/startup/Bootstrap
~
 Thanks Chuck
 lbrtchx

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message