tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Crowther <Peter.Crowt...@melandra.com>
Subject RE: Apache 2.2.3 with mod_jk 1.20 loosing connection with a cluster of two Tomcat 6.0.10
Date Mon, 24 Nov 2008 14:52:16 GMT
> From: √Čric Gauthier [mailto:EGauthier@labvolt.ca]
[...]
> I assume this is a Tomcat issue since the threads are going
> berserk, but I am unsure at this point.
[... good description elided...]

Thanks for a comprehensive description of the problem.

It *may* be an application or environment issue, especially as both app servers fail at nearly
the same time.  Common mode failures such as this could indicate:

- Shortage of memory on the server causing OutOfMemoryException, after which anything could
happen!

- If your application uses other resources (such as a database), is the database doing anything
unusual at around these times?  Suddenly long response times, down for maintenance, or similar?

- If the app is an Internet application, is one of the web crawlers suddenly hitting it with
a massive load and saturating it?

- Is the virtual machine being starved of resources at these times due to something else happening
on the host?

All just vague ideas at this point, and I suspect you have already considered and rejected
them!

                - Peter

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message