tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Moore <...@microps.com>
Subject Configuration Quandary - Servicing static page from app root
Date Wed, 26 Nov 2008 23:43:13 GMT
OS - CentOS 4.7
Tomcat - apache-tomcat-5.5.23.tar.gz
Apache - httpd-2.0.59.tar.gz (compiled on that machine)
Connector - tomcat-connectors-1.2.21-src.tar.gz (compiled on that machine)


I'm trying to serve a static page (which will redirect elsewhere but 
that is not the issue) that will be found when the user uses the raw 
domain name URL.  i.e.

http://www.somedomain.com

Currently this particular webapp requires the fairly usual:

http://www.somedomain.com/appname/servlet_controller

with the directory structure:

/webapps/somedomain/appname

and works just fine.. (Note: I have a LOT of web apps on this machine 
with various domains, hence the directory structure)

In the base configuration file that is "include"d in httpd.conf  that is 
working for the URL

http://www.somedomain.com/appname/servlet_controller

I have..

==========
<VirtualHost www.somedomain.com>
    ServerName www.somedomain.com

     Alias /appname "/usr/local/tomcat/webapps/somedomain/appname"

    <Directory "/usr/local/tomcat/webapps/somedomain/appname">
        Options Indexes FollowSymLinks
        DirectoryIndex index.html index.htm index.jsp
    </Directory> 

    DocumentRoot "/usr/local/tomcat/webapps/somedomain/"

     JkMount /appname/servlet_controller  ajp13
    JkMount /appname/*.jsp  ajp13
</VirtualHost>
=============

What I would like to do is place an index.html in, for example, the 
directory

/webapps/somedomain/index.html

..and have the URL

http://www.somedomain.com

...load that index.html  (the above path location can be different I'm 
just assuming that would be a good place)

So far I have had no luck.. (I seem to remember doing this back in 
Tomcat3 but either my brain has deteriorated severely or something has 
changed and I don't "get it" yet..)

I have tried ADDING variations on the following several settings with no 
luck...:

============
Alias / "usr/local/tomcat/webapps/somedomain"

<Directory "/usr/local/tomcat/webapps/somedomain">
        Options Indexes FollowSymLinks
        DirectoryIndex index.html index.htm index.jsp
 </Directory>

JkMount  / ajp13
===============

...and reread all of the docs....

Except for when I added the "JkMount / ajp13" I got a 404 returned.. 
When I added the JkMount then I got a blank page (no error), but the 
index.html page did not load...

I would appreciate a kick up the side of the head to get me going here.. 
I'm feeling rather clueless at the moment...

Thank you..

John....


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message