tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Connectors and apache with mpm worker
Date Fri, 21 Nov 2008 18:56:35 GMT
Martin Spinassi wrote:
> Hi everyone!
> 
> 
> I'm doing some performance tests under apache and tomcat using jakarta
> connectors.
> 
> Searching around, I've read about apache-worker (not jakarta), to make
> it multi-process and multi-thread, but I'm having some troubles with
> connectors now.
> 
> 
> Here is the output of jk_mod_log:
> 
> 
> [error] jk_handler::mod_jk.c (2410): Could not get endpoint for
> worker=worker1
> [info] jk_handler::mod_jk.c (2476): Service error=0 for worker=worker1
> 
> 
> And here is my workers.properties:
> 
> 
> worker.worker1.port=8009
> worker.worker1.host=127.0.0.1
> worker.worker1.type=ajp13
> worker.maintain=30
> 
> worker.worker1.connection_pool_size=1
> worker.worker1.fail_on_status=503
> 
> worker.list=worker1
> 
> 
> If I browse the site, it loads really faster, but with some little more
> traffic (2 connections by second), I get all those errors at jk_mod_log.
> 
> 
> Can you give me some help? I just can't find what to modify or what is
> wrong with my configuration.
> 
> 
I think you should state on which platform you're running this, because 
it may have an impact on whether it is or not a good idea to use the 
worker mpm in the first place.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message