tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Ludwig <mil...@gmx.de>
Subject Re: tomcat 5.5.20 security issue
Date Tue, 25 Nov 2008 00:00:56 GMT
aymen83 schrieb am 24.11.2008 um 05:45:11 (-0800):
> I???m trying to run a web service on tomcat 5.5.20 but I have this
> error. I???m not expert in tomcat so if someone can help me?
> 
> java.lang.NoClassDefFoundError:
> com/sun/org/apache/xml/internal/security/Init
> 
>         at
> com.sun.xml.wss.impl.SecurableSoapMessage.<clinit>(SecurableSoapMessage.java:75)

You said you're using Java 1.5, which, as Chuck observed, doesn't have
the class "com.sun.org.apache.xml.internal.security.Init". This is new
in 1.6.

You can try Apache's xmlsec.jar and then you possibly have to register
this as the new security provider to supplant the built-in one. Maybe
this is possible in the same way as substituting Apache's Xalan (XSLT)
for SUN's version of Xalan, which is under "com.sun.org.apche.xalan".

In case your application explicitly wants the "com.sun.org.apache"
version, you'll probably have to upgrade.

Michael Ludwig

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message