tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: HELP!!! java.lang.NoClassDefFoundError running CXF-based client inTomcat
Date Wed, 26 Nov 2008 15:16:13 GMT
> From: Steve Cohen [mailto:scohen@javactivity.org]
> Subject: HELP!!! java.lang.NoClassDefFoundError running
> CXF-based client inTomcat
>
> I am beginning to think the problem is not a missing class
> but a class conflicting with something in Tomcat.

Highly likely.  First just look at the names of the Tomcat-supplied jars and see if any match
or are very similar to the ones you have in your webapp.  (Can't tell you which directories
to look at, since that varies with the version of Tomcat you're using, which you didn't bother
to tell us.)

If that doesn't turn up anything, try finding a tool to scan jars and report duplicate classes
(sorry, I don't know of any specific ones, but there must be some out there).

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message