tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "BEN HMIDA aymen" <aymen.benhm...@tunisiana.com>
Subject RE: tomcat 5.5.20 security issue
Date Mon, 24 Nov 2008 15:24:35 GMT
Thanks for the response. In my pom.xml i'm using the tag 
<jdk>!1.6</jdk> to make the compiler use jdk 1.6 or any other version present
in the machine. But I have to keep the version to 1.5 because the running platforme is using
it.
I tried to download the xmlsec.jar and placed it in my WEB-INF/lib but no success

-----Message d'origine-----
De : Caldarale, Charles R [mailto:Chuck.Caldarale@unisys.com] 
Envoyé : lundi 24 novembre 2008 16:16
À : Tomcat Users List
Objet : RE: tomcat 5.5.20 security issue

> From: aymen83 [mailto:aymen.bhmida@yahoo.fr]
> Subject: tomcat 5.5.20 security issue
>
>
> java.lang.NoClassDefFoundError:
> com/sun/org/apache/xml/internal/security/Init

Move up to a 1.6 JVM.  It appears the version of Spring you're using is expecting to have
the 1.6 libraries available.  There's probably some jar you could add that contains the missing
classes if you insist on staying with 1.5, but I don't know what it is.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org






---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message