tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hisham Farahat" <hishamfara...@gmail.com>
Subject Re:
Date Mon, 27 Oct 2008 09:18:06 GMT
Thanx for your reply
1- yes , the log has this exception each time i need to login :

[Root exception is java.net.ConnectException: Connection refused: connect]]

2- What do you mean by functioning?
3-  this is the realm in server.xml ( By the way i tried to put it in both
server.xml and context.xml ,with both the same problem occured)
<Realm className="org.apache.catalina.realm.JNDIRealm" debug="99"
connectionURL ="ldap://company.com:389/" connectionName=
"CN=tomcat,CN=Users,DC=company,DC=com" connectionPassword= "***"
alternateURL ="ldap://192.168.205.2:389/" userSubtree = "true"
referrals="follow" userSearch="###" userBase="DC=company,DC=com"
roleBase="CN=Users,DC=company,DC=com" roleName="description"
roleSearch="member={0}" roleSubtree = "true" allRolesMode="AuthOnly" />

4- no, just 20% of the times when i logged in. sometimes it happens once a
day and sometimes i could not even login it contuisly doing this issue.

5- no randomly

6- the whole server takes 500 MB, it 's not that much.

7- if with busy you mean, how frequent users use it. Then no it is not, im
the only one it still in testing phase.

8- Windows server 2003

9- I think yes, if not then how users are logging to their domain using AD
accounts
On Mon, Oct 27, 2008 at 11:52 AM, Serge Fonville
<serge.fonville@gmail.com>wrote:

> I would need a little bit more information about your environment
>
> Have you looked at te loggingHow is your network functioning
> How is the realm configured
> Has it always been like this or at some point
> Are there specific times of day it occurs
> How is the memory usage of tomcat
> How busy is tomcat
> What OS is it running on
> Can you use ldap manually without errors
>
> Regards,
>
> Serge Fonville
>
>
> On Mon, Oct 27, 2008 at 9:18 AM, Hisham Farahat <hishamfarahat@gmail.com
> >wrote:
>
> >  Dear All,
> > I have a problem with my web application. I configured tomcat 6.0 to
> > authenticate users through Realm ( LDAP), it connects to an active
> > directory
> > server. Everything seems OK, but sometimes the connection could not be
> > established ( Connection refused ) and it continues with this state for ~
> > 10
> > minutes. Stopping and starting tomcat again won't affect anything, I
> should
> > restart the machine so that users can access the web application normally
> (
> > or just wait for 10 minutes). How can I solve this problem?
> > Regards,
> > --
> > Hisham Farahat
> >
>



-- 
Hisham Farahat

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message