tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Serge Fonville" <serge.fonvi...@gmail.com>
Subject Re: SSL Host
Date Fri, 10 Oct 2008 15:48:10 GMT
Chuck,
Thanks for your answer.

I tried and it works

Just one thing;
If I access https://*.autumn.nl (which shouldn't exist, I get the
defaulthost, instead I wan't to get a 404 of some sort, indicating that that
site does not exist?
Do I need to add a 404-host to either engine as a default host service which
just throws a 404 or something

Thanks a lot so far,

Serge Fonville

On Fri, Oct 10, 2008 at 5:27 PM, Caldarale, Charles R <
Chuck.Caldarale@unisys.com> wrote:

> > From: Serge Fonville [mailto:serge.fonville@gmail.com]
> > Subject: Re: SSL Host
> >
> > I read both and what I still don't get is:
> > How do I specify a connector to a host?
>
> You can't.  You would need multiple <Service> elements, each with its own
> nested <Connector> and corresponding <Host> elements.
>
> Alternatively, to keep the configuration much simpler, use valves as Chris
> suggested to accept or reject requests based on whatever rules you like.
>
>  - Chuck
>
>
> THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY
> MATERIAL and is thus for use only by the intended recipient. If you received
> this in error, please contact the sender and delete the e-mail and its
> attachments from all computers.
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message