tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Ozarchuk <jdo...@yahoo.com>
Subject Native library issue on RHEL5
Date Thu, 02 Oct 2008 19:16:03 GMT
Hello,
 
I am running Apache-tomcat 6.0.1.14 
on Redhat Enterprise 5.2, and I am having trouble getting Catalina.sh to use the Apache Tomcat
Native Library.  I have run configure, make, and make install on 
the Native (tomcat-native-1.1.10-src) and it has installed libraries in 
/usr/local/apr/lib:
 
[root@jdotest ~]# ll 
/usr/local/apr/lib
total 
2360
-rw-r--r-- 1 root root 1518062 Oct  
2 11:21 libtcnative-1.a
-rwxr-xr-x 1 root root     893 Oct  
2 11:21 libtcnative-1.la
lrwxrwxrwx 1 root root      23 Oct  
2 11:21 libtcnative-1.so -> libtcnative-1.so   
            .0.1.10
lrwxrwxrwx 1 root root      23 Oct  
2 11:21 libtcnative-1.so.0 -> libtcnative-1.               
so.0.1.10
-rwxr-xr-x 1 root root  853799 Oct  
2 11:21 libtcnative-1.so.0.1.10
drwxr-xr-x 2 root root    4096 Oct  
2 11:21 pkgconfig
 
I have added this path to 
$CATALINA_HOME/Catalina.sh:
 
JAVA_OPTS="-Djava.library.path=/usr/local/apr/lib/"
 
When I run “Catalina.sh start” to 
startup the Tomcat server, it still is not detecting these libraries, per 
Catalina.out:
 
INFO: The Apache Tomcat Native 
library which allows optimal performance in production environments was not 
found on the java.library.path: /usr/local/apr/lib/
Oct 2, 2008 12:59:40 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 
on http-8080
Oct 2, 2008 12:59:40 PM 
org.apache.catalina.startup.Catalina load
INFO: Initialization processed in 
529 ms
 
Am I missing something here?   Any 
help is greatly appreciated.  Thank you.


      
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message