tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gregor Schneider" <>
Subject Re: How to make to Apache-Tomcat 6.0.13 to support all of SSLv2/SSLv3 and TLS protocols
Date Wed, 03 Sep 2008 07:44:18 GMT
On Wed, Sep 3, 2008 at 8:20 AM, Suresh Kumar J <> wrote:
> Am runing Harmony JRE in this case. Is this error related to Harmony JRE or
> Tomcat?.

Suresh, sorry, but unfortunately my cristal ball is not available...

Try it with the original SUN JDK - Not JRE and see if it works.

I have to apologize for the hint "ALL" since "all" (notice that it's
all small letters) only is available only in the https-connector when
using APR (Apache Portable Runtime).

However, maybe this piece from the docs gives you an idea:

The encryption/decryption protocol to be used on this socket. It is
not recommended to change this value if you are using Sun's JVM. It is
reported that IBM's 1.4.1 implementation of the TLS protocol is not
compatible with some popular browsers. In this case, use the value


Seems some JDKs might have a problem with SSL.

Therefore, again, try SUN's original JDK.

what's puzzlin' you, is the nature of my game
gpgp-fp: 79A84FA526807026795E4209D3B3FE028B3170B2
gpgp-key available @

To start a new topic, e-mail:
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message