tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From André Warnier ...@ice-sa.com>
Subject Re: Tomcat 5.5 / Windows / procrun ?
Date Sun, 21 Sep 2008 23:27:24 GMT
Caldarale, Charles R wrote:
>> From: André Warnier [mailto:aw@ice-sa.com]
>> Subject: Tomcat 5.5 / Windows / procrun ?
>>
> 
>> It also contains a file "service.bat" which is described nowhere
> 
> It's described here:
> http://tomcat.apache.org/tomcat-5.5-doc/windows-service-howto.html
> which is reachable from the Setup section of the doc.
> 
>> which leads to a page mentioning "procrun 1.0", but in
>> the same breath indicating that it is now obsolete.
> 
> Not sure why it says obsolete (current version is 1.0.1), since I think everything in
there is still accurate, although the tomcat5w.exe program provides a much easier mechanism
to change the parameters.
> 
Since the windows-service-howto is marked obsolete, I did not "count" it 
as a valid source for the procrun parameters.

>> But I found nowhere a link to download this procrun in binary form.
> 
> That's an unfortunate issue.  You can find binaries for various Windows flavors here:
> https://svn.apache.org/repos/asf/tomcat/tc6.0.x/trunk/res/procrun/
> (Change the name of the executables to tomcat5*.exe for the older level.)

Do you want to elaborate on the unfortunate issue of why the binaries 
are not available in the Commons, but are available on the Tomcat SVN ?

A related question : on the Tomcat SVN site, there are indeed various 
flavors, but on my laptop after installing Tomcat with the installer, I 
have only one flavor.  Does the installer pick the right one for the 
platform ?
And also, in the zip release of Tomcat, it seems that there is only one 
of each exe.  So which flavor is that ?

> 
>> - the documentation of this procrun (or whatever is related to it for
>> Tomcat), on the Tomcat site, is out-of-date and does not match the
>> version of procrun that is being used above.
> 
> Actually, I think it's pretty close.
> 
I have not actually compared with the one in the Commons, nor tested any 
of this.  I was writing "is out-of-date" because that's what's written 
in the how-to pages on the Tomcat site.
Maybe someone should just remove that out-of-date comment, it makes the 
whole thing all the more confusing.
Do you know where/how someone should suggest this ?

Thanks for the clarification on jsvc. That's at least one item that can 
be removed from the list.

Actually, I still have a question, or rather some assertions in need to 
be confirmed or denied :

1) One can download the zip version of Tomcat 5.5 (and 6 ?), and use the 
startup scripts to start a command-window instance of Tomcat. In that 
case, the executable shown running will be java.exe.
2) But starting Tomcat via these scripts will not allow to run Tomcat as 
a Windows Service.
3) To run Tomcat as a Service, you have to use the Tomcat(x).exe.
4) But you can use the tomcat(x).exe from the zip distribution, it is 
the same as the one installed by the Windows Installer.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message