tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Schönhaber <tomcat-us...@list-post.mks-mail.de>
Subject Re: https problem after upgrading from Tomcat 5.5 to Tomcat 6
Date Sat, 06 Sep 2008 09:25:04 GMT
randomw wrote:

> I've been trying to upgrade from Tomcat 5.5.26 to Tomcat 6.0.18 for the past
> couple days but just cannot get https to work.  Everything works as expected
> in Tomcat 5.5.  Plain old http works in Tomcat 6, but the moment I try to
> switch to https, the connection just times out.
[...]
> My server.xml looks like this:

>     &lt;Connector port="443" scheme="https" secure="true"
>       clientAuth="false" sslProtocol="TLS"
>       keystoreFile="path to my.keystore" keystorePass="myPassword"
>       maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
>       acceptCount="100" enableLookups="false"
>       connectionTimeout="20000" disableUploadTimeout="true"
>       /&gt;
> 
> 
> Any ideas what might be the trouble here?  I'm pretty much at the end of my
> rope.  All other references to problems of this sort that I can find relate
> to using APR, which I'm not.

Try adding SSLEnabled="true" to the Connector's attributes.

Regards
   mks

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message