tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Barry Fawthrop <ba...@isscp.com>
Subject Re: Remote RSS Feeds
Date Wed, 03 Sep 2008 20:47:27 GMT


Martin Gainty wrote:
> take a look at this fairly intuitive tutorial at
> http://java.sun.com/developer/technicalArticles/javaserverpages/rss_utilities/
> /WEB-INF/rssutils.tld
> WEB-INF/lib/rssutils.jar 
> ?
> Martin 
> ______________________________________________ 
> Disclaimer and confidentiality note 
> Everything in this e-mail and any attachments relates to the official business of Sender.
This transmission is of a confidential nature and Sender does not endorse distribution to
any party other than intended recipient. Sender does not necessarily endorse content contained
within this transmission. 
> 
> 
>> Date: Wed, 3 Sep 2008 16:00:16 -0400
>> From: barry@isscp.com
>> To: users@tomcat.apache.org
>> Subject: Remote RSS Feeds
>>
>> My very first JSP application
>> (perhaps too much for my first app.)
>>
>> Trying setup and home portal page.
>> That reads three remote RSS feeds (news, weather, etc...)
>> It will work for the first few seconds and then stops.
>>
>> I have to restart the tomcat 6.0.18 server and then it all works again..
>>
>> (1) Tried using my own DocumentBuilder.parse
>>     Now
>> (2) Using sun.com  rssutils.tld
>>
>> Both Report FileNotFoundException.
>>
>>
>> As I say it works, and then stops So it's not a code issue.
>>
>> It would appear to me, that it remembers the connection and the blocks
>> that connection after it closes.
>>
>> I have tried connecting and then waiting and connecting again. Thinking
>> that the RSS site only allows a one connection within one second.
>> So it's not that.
>>
>> It appears more that the connection stays open or is blocked from making
>> a second connection.
>>
>> Any help Please!!
>>
>> ---------------------------------------------------------------------
>> To start a new topic, e-mail: users@tomcat.apache.org
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
> 
> _________________________________________________________________
> Get more out of the Web. Learn 10 hidden secrets of Windows Live.
> http://windowslive.com/connect/post/jamiethomson.spaces.live.com-Blog-cns!550F681DAD532637!5295.entry?ocid=TXT_TAGLM_WL_domore_092008

Martin

Thank You,

But as I said it works, but then quits working.
I have it installed according to the same link, and proof that is works
is I get the page, and I can press refresh a number of times and still
get the feed. BUT  if I wait a few seconds (25+) then it quits and comes
back with a 500 Error code which breaks down to a FileNotFoundException
 error.

It's the sporadic nature on/off that is puzzling


Thanks All
Barry

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message