tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From br1 <myrealbr...@myrealbox.com>
Subject JK and IIS - troubles?
Date Tue, 30 Sep 2008 21:29:56 GMT

Dear all,

I am experiencing a weird problem happening between IIS and Tomcat: it seems
that the JK connector is hanging IIS. 

A badly behaving Tomcat app is filling up AJP connections due to some DB
connection problems. Nothing strange so far, we had these kinds of problems
already, but this time this is causing IIS to hang. 
Simply restarting the failing app's Tomcat instance causes IIS to start
again like it was simply frozen. 
Instead, restarting IIS makes obviously the whole site restart, except for
the failing application. 

I struggled with this problem for the past months on two servers, and just
configured an additional IIS on our dedicated Tomcat machine with the same
results. Configuration is as follows:
IIS 5
JK 1.2.26 (/maybe some other 1.2.2x version but cannot be sure)
Tomcat 5.5.9 / 5.5.27
JDK 1.5.0_12 / 1.5.0_16 / 1.6.0_07
About 40 workers and Tomcats

Since we use Tomcat since version 3 and Jk since before year 2k - sorry
Linux guys - on Windows platforms without a single serious problem, I am a
bit sorry not to be able to solve this one by myself now.
Clearly the application needs patching, and the affected Tomcat is
restarting hourly now, but to me the JK connector should be fixed if it is
causing this problem. 

Kindly let me know what should  I provide in order to investigate about
this. 

Thank you in advance,
Br1
-- 
View this message in context: http://www.nabble.com/JK-and-IIS---troubles--tp19750760p19750760.html
Sent from the Tomcat - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message