tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maduranga Kannangara <madura...@koodos.com>
Subject Re: Tomcat does not shutdown properly and kill -3 does not work!
Date Wed, 06 Aug 2008 08:59:50 GMT
Hi,

A friend of mine said it was not due to ActiveMQ that Tomcat does not
shutdown properly, however I added a kill command to shutdown.sh script
which is NOT good at all, I understand.

In MAC (10.5) kill -3 seems working, but its a blind path which gets me
nowhere. I do not get a trace of the threads. Its a wrong path I am
following. What I need simply is a clean shutdown on Tomcat :-)

Environment:
Tomcat: 5.5.20
JVM: 1.5.0_09-b01
OS: Red Hat Enterprise Linux AS release 4 (Nahant Update 2)

Please help! :-)

Thanks again
Maduranga




On 5/8/08 10:59, "Maduranga Kannangara" <maduranga@koodos.com> wrote:

> Hello,
> 
> There is an issue with my Tomcat instance where I have to kill it using ­9
> all the time.
> 
> This is my application environment:
> An active-mq queue is used inside my application war.
> Tomcat version: 5.x
> OS: Redhat Linux
> 
> However I was unable to get trace using kill ­3 as I saw in some of the
> threads in this mailing list.
> 
> How can I ensure proper shutdown of Tomcat?
> 
> Thanks in advance!
> Maduranga
> 


-- 
Koodos - stylish brads, smart prices
http://www.koodos.com



---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message