tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Olivier Lamy" <ol...@apache.org>
Subject Re: Weird stack trace when reloading a webapp
Date Fri, 08 Aug 2008 09:39:24 GMT
Ok I will search and try reordering filters.

Thanks for your time !

--
Olivier

2008/8/8 Johnny Kewl <john@kewlstuff.co.za>:
>
> ----- Original Message ----- From: "Olivier Lamy" <olamy@apache.org>
> To: "Tomcat Users List" <users@tomcat.apache.org>
> Sent: Thursday, August 07, 2008 11:21 PM
> Subject: Re: Weird stack trace when reloading a webapp
>
>
>> Hi,
>> Thanks for your reponse but undeploy/redeploy don't save me same issue
>> :-(.
>
> Damn!.... I was hoping ;)
>
> Well... it looks like a struts framework so I think you need to ask some
> question in their mailing lists...
> All I can tell from this is that they seem to be hiding xerces in the
> META-INF folder...
> and they have a custom classloader trying to access it....
> You seem to be making a filter... and the framework seems to want a web app
> for its classloader... but the webapp is down.
>
> So you calling Tiles or something... and that wants to live in a webapp, but
> you in a filter... maybe, but its the kind of thing that should be showing
> in your dev env?
> Is it your application? If not ask the supplier...
>
> Some guesses for you... the order of filters is important... maybe yours
> should be behind all the framework filters...
> Perhaps <load-on-start> will get the webapp with all this framework stuff in
> it to start and make the cl happy.
>
> Thats the problem with frameworks... always have to ask more than one user
> group ;)
>
> Its a tricky problem I think and you'll have to talk to the guys that made
> your frameworks...
>
> Good luck... Sorry... outta idea's, maybe google will get you there
>
>> Olivier
>>
>> 2008/8/7 Johnny Kewl <john@kewlstuff.co.za>:
>>>
>>> ----- Original Message ----- From: "Olivier Lamy" <olamy@apache.org>
>>> To: <users@tomcat.apache.org>
>>> Sent: Thursday, August 07, 2008 5:17 PM
>>> Subject: Weird stack trace when reloading a webapp
>>>
>>>
>>>> Hi,
>>>> I use the ant deploy target :
>>>>  <deploy url="${url}" username="${tomcat.user}"
>>>> password="${tomcat.password}"
>>>>         path="/{webPath}" localWar="${warPath}" update="true"
>>>> config="${contextPath}" />
>>>>
>>>> But in catalina.out, I have the following stack trace :
>>>>
>>>> INFO: Deploying web application archive dotw-trans.war
>>>> 2008-08-07 15:04:38,942 INFO  impl.BasicTilesContainer : Initializing
>>>> Tiles2 container. . .
>>>> 2008-08-07 15:04:39,177 INFO  impl.BasicTilesContainer : Tiles2
>>>> container initialization complete.
>>>> 2008-08-07 15:04:39,185 INFO  access.TilesAccess : Publishing
>>>> TilesContext for context: org.apache.catalina.core.Appli
>>>> cationContextFacade
>>>> 2008-08-07 15:04:39,247 INFO  filter.DotwFilterDispatcher : init
>>>> DotwFilterDispatcher with encoding : UTF-8
>>>> Aug 7, 2008 3:04:40 PM org.apache.catalina.loader.WebappClassLoader
>>>> findResourceInternal
>>>> INFO: Illegal access: this web application instance has been stopped
>>>> already.  Could not load META-INF/services/org.ap
>>>> ache.xerces.xni.parser.XMLParserConfiguration.  The eventual following
>>>> stack trace is caused by an error thrown for de
>>>> bugging purposes as well as to attempt to terminate the thread which
>>>> caused the illegal access, and has no functional
>>>> impact.
>>>> Aug 7, 2008 3:04:40 PM org.apache.catalina.core.StandardContext start
>>>> SEVERE: Error filterStart
>>>> Aug 7, 2008 3:04:40 PM org.apache.catalina.core.StandardContext start
>>>> SEVERE: Context [/dotw-trans] startup failed due to previous errors
>>>>
>>>> Any idea on the Could not load
>>>> META-INF/services/org.apache.xerces.xni.parser.XMLParserConfiguration.
>>>>
>>>> My en is :
>>>> - apache-tomcat-6.0.18
>>>> - jdk1.6.0_06
>>>> - solaris 10
>>>>
>>>> Any idea ?
>>>>
>>>> Thanks,
>>>> --
>>>> Olivier
>>>
>>> Oliver is that the whole error message or did you abreviate it?
>>> Does is say anything about a POST...
>>>
>>> I tell you why, on complex applications I've seen something similar...
>>>
>>> Anyway try this.... before you redeploy... open /manager/html and
>>> UNDEPLOY
>>> the old one... then run your script...
>>> If it is the same thing... you wont get the error because its actually
>>> happening in the undeploy...
>>> If that works then add another section to your ant script... first
>>> undeploy... then redeploy...
>>>
>>> If it is the same thing... I've only noticed it on very complex apps....
>>> Other thing I've noticed is that even when you get this weird message...
>>> the
>>> redeploy does work.
>>> And you cant debug it... because TC is killing the thing... ide wont trap
>>> it...
>>> And I think it only happens when there are classloaders in the webapp
>>> classloader... which would explain why the webapp class loader cant let
>>> go... the child still has references... anyway try the above, and I dont
>>> think its too serious... its a last complaint before it gets a bullet
>>> between the eyes ;)
>>>
>>> .... maybe its the same thing...
>>>
>>> ---------------------------------------------------------------------------
>>> HARBOR : http://www.kewlstuff.co.za/index.htm
>>> The most powerful application server on earth.
>>> The only real POJO Application Server.
>>> See it in Action : http://www.kewlstuff.co.za/cd_tut_swf/whatisejb1.htm
>>>
>>> ---------------------------------------------------------------------------
>>>
>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To start a new topic, e-mail: users@tomcat.apache.org
>>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>>> For additional commands, e-mail: users-help@tomcat.apache.org
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To start a new topic, e-mail: users@tomcat.apache.org
>> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: users-help@tomcat.apache.org
>>
>>
>
>
> ---------------------------------------------------------------------
> To start a new topic, e-mail: users@tomcat.apache.org
> To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: users-help@tomcat.apache.org
>
>

---------------------------------------------------------------------
To start a new topic, e-mail: users@tomcat.apache.org
To unsubscribe, e-mail: users-unsubscribe@tomcat.apache.org
For additional commands, e-mail: users-help@tomcat.apache.org


Mime
View raw message